Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 137936 - Debugger module is not installed
Debugger module is not installed
Status: VERIFIED FIXED
Product: javafx
Classification: Unclassified
Component: Debugger
6.x
All All
: P2 (vote)
: TBD
Assigned To: Alexey Butenko
issues@javafx
FXPLUGIN_PREVIEW_WAVED
:
: 136952 (view as bug list)
Depends on: 136318
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-23 09:39 UTC by Alexandr Scherbatiy
Modified: 2008-08-22 11:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE screen-shot (96.67 KB, image/png)
2008-06-23 09:40 UTC, Alexandr Scherbatiy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2008-06-23 09:39:36 UTC
Steps to reproduce:

- Install a JavaFX Script plugin
- Uninstall the JavaFX Script plugin
- Install new version of the JavaFX Script plugin
  The Information dialog appears: 'Plugins "JavaFX Debugger - API" is already installed'
Comment 1 Alexandr Scherbatiy 2008-06-23 09:40:08 UTC
Created attachment 63237 [details]
IDE screen-shot
Comment 2 Alexei Mokeev 2008-07-09 14:35:49 UTC
Unclear yet. Looks like side effect of some other bug. Sasha will provide more information.
Comment 3 Alexei Mokeev 2008-07-09 14:38:33 UTC
See also http://www.netbeans.org/issues/show_bug.cgi?id=135779
Comment 4 Alexei Mokeev 2008-07-09 14:44:02 UTC
Blocked by 136318. If we will allow Debugger un-installation then it will force Java Debugger de-installation
Comment 5 Lark Fitzgerald 2008-07-10 17:48:41 UTC
Note: There is a workaround to this issue.  The user can install the Module Manager plugin and uninstall each fx 
module manually,
org-netbeans-modules-api-debugger-javafx.jar
org-netbeans-modules-debugger-javafx-project.jar
org-netbeans-modules-javafx-debug.jar
org-netbeans-modules-javafx-lexer.jar
org-netbeans-modules-javafx-lib.jar
org-netbeans-modules-javafx-platform.jar
org-netbeans-modules-javafx-source.jar 

or they can uninstall/reinstall NB.  Users of the installer build will not run into this issue.
Comment 6 Lark Fitzgerald 2008-07-14 15:27:21 UTC
*** Issue 136952 has been marked as a duplicate of this issue. ***
Comment 7 Andrey Yamkovoy 2008-07-25 09:25:30 UTC
Fixed by fix for another issue.
Comment 8 Alexandr Scherbatiy 2008-08-22 11:47:37 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo