Bug 13748 - I18N - Revision Explorer does not work with Localized PVCS and VSS
I18N - Revision Explorer does not work with Localized PVCS and VSS
Status: RESOLVED FIXED
Product: obsolete
Classification: Unclassified
Component: vcsgeneric
-FFJ-
PC Windows ME/2000
: P2 (vote)
: -FFJ-
Assigned To: issues@obsolete
issues@obsolete
: I18N
Depends on: 13975
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-19 15:19 UTC by Unknown
Modified: 2008-11-11 15:33 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
localized file. It is located at modules/locale (182.81 KB, application/octet-stream)
2001-07-24 15:29 UTC, Unknown
Details
Japanese PVCS, vlog output (1.92 KB, text/plain)
2001-07-24 15:30 UTC, Unknown
Details
English PVCS, vlog output (same revision information with vlog.txt) (1.71 KB, text/plain)
2001-07-24 15:32 UTC, Unknown
Details
The corrected JAR (191.90 KB, application/octet-stream)
2001-07-26 17:08 UTC, Martin Entlicher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2001-07-19 15:19:31 UTC
The revision information is not displayed in Revision Explorer. Only file name
is displayed. I guess the following Bundle.properties has been translated
correctly for localized PVCS and VSS.

org/netbeans/modules/vcs/advanced/config/vcs/commands/Bundle.properties
Comment 1 Martin Entlicher 2001-07-19 18:18:39 UTC
Since I don't have Japan PVCS and Japan VSS, it's hard for me to say
why it does not work.
Just several questions that came to my mind:

1) Did you really translate the file
org/netbeans/modules/vcs/advanced/config/vcs/commands/Bundle.properties
exactly with the output of Japan vlog and ss history commands?

2) Did you select the Japan PVCS/VSS profile in the Customizer? It's
name is followed by the localized string
(i.e. PVCS (Unix) - \u30ed\u30fc\u30ab\u30e9\u30a4\u30ba\u6e08\u307f)

If the above is right and the information is still not displayed, can
you please attach the complete output of REVISION_GETTER command? It's
accessible on the Runtime tab under VCS Commands node.
Thanks. 
Comment 2 Unknown 2001-07-24 15:29:19 UTC
Created attachment 1957 [details]
localized file. It is located at modules/locale
Comment 3 Unknown 2001-07-24 15:30:51 UTC
Created attachment 1958 [details]
Japanese PVCS, vlog output
Comment 4 Unknown 2001-07-24 15:32:07 UTC
Created attachment 1959 [details]
English PVCS, vlog output (same revision information with vlog.txt)
Comment 5 Unknown 2001-07-24 15:35:33 UTC
I've attached localized file. And vlog output.

Thank you for your suggestions. The revision explorer works!
But I need to add Bundle_ja.properties in modules/vcsgen.jar, NOT 
modules/locale/vcsgen_ja.jar. Is it correct way to localize?
If revision explorer should work with Bundle_ja.properties in 
modules/locale/vcsgen_ja.jar, could you review our vcsgen_ja.jar?
Comment 6 Martin Entlicher 2001-07-25 15:34:22 UTC
You have said, that the Revision Explorer works. So I suppose, that we
can close this issue as Fixed. Do you agree?
However, I'm confused by the fact, that the Bundle_ja.properties needs
to be in vcsgen.jar and not in vcsgen_ja.jar. I can not imagine why it
should be necessary. Since all *_ja.* files are put into vcsgen_ja.jar
by the build process, this can cause problems. The vcsgen_ja.jar
you've sent me seems right, however I'm not able to test it since I
don't have a Japanese localization.
Comment 7 Martin Entlicher 2001-07-26 17:07:24 UTC
Using the Japanese vlog.txt you supplied I was able to reproduce the
problem. I didn't found the real source of the problem yet (it's
somewhere in class loaders), but I have at least a workaround, that
should work.
Just create folder "vcs/commands" in vcsgen_ja.jar and put
Bundle_ja.properties from
"org/netbeans/modules/vcs/advanced/config/vcs/commands/Bundle_ja.properties"
Comment 8 Martin Entlicher 2001-07-26 17:08:54 UTC
Created attachment 1987 [details]
The corrected JAR
Comment 9 Martin Entlicher 2001-07-26 17:24:17 UTC
The same should probably be done for vcs/list/Bundle_ja.properties:
copy
org/netbeans/modules/vcs/advanced/config/vcs/commands/Bundle_ja.properties
to vcs/list/Bundle_ja.properties

I mark this as fixed, if the above fix will not work reopen the issue
with some further description.
I've filled an issue #13975 in which I've described the problem in a
more general way. I'll look for a fix to the dev build.
Comment 10 Martin Entlicher 2001-07-26 17:24:43 UTC
The same should probably be done for vcs/list/Bundle_ja.properties:
copy
org/netbeans/modules/vcs/advanced/config/vcs/list/Bundle_ja.properties
to vcs/list/Bundle_ja.properties

I mark this as fixed, if the above fix will not work reopen the issue
with some further description.
I've filled an issue #13975 in which I've described the problem in a
more general way. I'll look for a fix to the dev build.
Comment 11 Unknown 2001-07-27 10:36:57 UTC
Thank you very much for your providing workaround. That solution work 
fine.
I created both vcs/commands/Bundle.properties and 
vcs/list/Bundle.properties. The Revision Explorer and Status work 
fine with this solution. I also update 10239 because this bug depends 
on same reason.
I've verified with Pilsen Build 010724_ja in the following 
environemnt:
   Windows 2000 SP1 Japanese
   PVCS Version Manager 6.6.10 Japanese
   Visual SourceSafe 6.0 Japanese
Comment 12 Keiichi Oono 2002-03-13 02:50:10 UTC
This issue has been fixed completely by fixing of 13975.
Comment 13 Jesse Glick 2002-12-23 16:34:52 UTC
Consistent use of the I18N keyword.
Comment 14 Marian Mirilovic 2008-11-11 15:32:55 UTC
fix the resolution
Comment 15 Marian Mirilovic 2008-11-11 15:33:55 UTC
closed/fixed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo