Bug 136938 - Addition of new Eclipse importer to standard distribution
Addition of new Eclipse importer to standard distribution
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Eclipse project importer
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jesse Glick
issues@platform
http://wiki.netbeans.org/EclipseProje...
: API_REVIEW_FAST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 17:50 UTC by Jesse Glick
Modified: 2008-06-13 16:03 UTC (History)
2 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2008-06-10 17:50:14 UTC
For M1 we plan to add the rewritten Eclipse import to the standard IDE distribution. Specifically, I think the best plan is:

1. The existing projectimport module will be deleted and removed from the Stable AU config.

2. projectimport.eclipse.core should be renamed projectimport (so it will appear as an upgrade of the old projectimport
module for anyone who happens to have that installed).

3. projectimport.eclipse.kit can be deleted.

4. projectimport.eclipse.{j2se,web} may be marked eager, so they will offer the right kinds of import to anyone who has
the corresponding Ant-based project types installed. projectimport (formerly projectimport.eclipse.core) will be marked
visible to AU.

5. projectimport.eclipse.{core,j2se} will be placed in the java cluster, and projectimport.eclipse.web in the enterprise
cluster. (Currently projectimport.eclipse.core uses various Java-specific APIs as we have not yet tried to implement a
non-Java-oriented importer for e.g. C++ projects.)

There is a small friend SPI between the core and domain modules which David plans to submit for review independently in
the M2 timeframe.
Comment 1 Jesse Glick 2008-06-10 17:52:38 UTC
Please comment on proposed changes.
Comment 2 David Konecny 2008-06-10 22:24:47 UTC
Re. "projectimport.eclipse.core should be renamed projectimport" - I thought we would rename it only in
project.xml/manifest but I can see that would not be possible. We are renaming module only to cater for people who
downloaded old Eclipse importer from AU. In such a case we want to update their module to newer one otherwise they would
end up with two modules confusingly providing action with the same name. Compared to rename approach how easy/difficult
would it be to just call module system to uninstall old module? Something what VCS was doing for old CVS module.
Comment 3 Jesse Glick 2008-06-11 02:59:43 UTC
It's not hard to uninstall the old module, though I am concerned about reliability - there were unreproducible bugs
relating to this functionality in vcscore. On the other hand, this is only an issue for one upgrade, whereas the module
name is forever, for I would be willing to adopt that approach instead.
Comment 4 David Konecny 2008-06-11 04:01:38 UTC
Let's aim for that then, I prefer it too. There will be also just handful of people who have old Eclipse import
installed anyway.
Comment 5 Jesse Glick 2008-06-11 23:32:33 UTC
Note that I could make pi.e.j2se a dependency of java.kit and pi.e.web a dep of web.kit. Then Eclipse importing
functionality would be built into the basic IDE functionality. But I think it would be preferable for this to be an
optional, visible component. Keeping pi.e.kit is not an option because it could not go into java cluster (dep on
pi.e.web would be illegal), enterprise cluster (would not appear in Basic IDE), or nb cluster (would not appear in other
brandings).
Comment 6 David Konecny 2008-06-11 23:41:14 UTC
RE. "I think it would be preferable for this to be an optional" - yeah I think it should be optional.
Comment 7 Jesse Glick 2008-06-12 02:41:36 UTC
Stages 1-4 (with 2 modified as agreed) done in: #6b1b800977b6
Comment 8 Jesse Glick 2008-06-13 16:03:26 UTC
Stage #5 in #2fe9f0512062.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo