Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 133639 - Deadlock after modifying properties of a module project
Deadlock after modifying properties of a module project
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Project
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jesse Glick
issues@java
61fixes2-fixed
: SIMPLEFIX, THREAD
: 134177 134486 135636 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 11:44 UTC by _ moser
Modified: 2008-07-10 15:03 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump fro the deadlock (23.13 KB, text/plain)
2008-04-22 11:46 UTC, _ moser
Details
Another thread dump for the deadlock (23.96 KB, text/plain)
2008-04-22 12:38 UTC, _ moser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ moser 2008-04-22 11:44:42 UTC
Not the first time I struggled over a deadlock which appears when I close the project properties dialog after adding a
project dependency to a module project from a suite. I have attached a stacktrace for this deadlock in NB RC2. But I
also noticed it in other daily builds.
Comment 1 _ moser 2008-04-22 11:46:29 UTC
Created attachment 60542 [details]
Thread dump fro the deadlock
Comment 2 _ moser 2008-04-22 12:37:53 UTC
Happened just again, the 3rd time today, after modifying the list of public packages. I'll attach a thread dump.
Comment 3 _ moser 2008-04-22 12:38:53 UTC
Created attachment 60548 [details]
Another thread dump for the deadlock
Comment 4 Jesse Glick 2008-04-23 15:13:08 UTC
Probably fixed in #a38a9a3078c0 which I will push to core-main.
Comment 5 _ moser 2008-04-23 17:12:02 UTC
Any chance to find the fix in the final 6.1?
Comment 6 Jesse Glick 2008-04-23 18:08:22 UTC
Too late for 6.1. Could go into some patch release, but I am not involved in that decision. If the deadlock is frequent
or reproducible, feel free to mark as a P2, which will improve the chances of it being noticed as a candidate for a
patch. Of course if you can verify the fix in a dev build, that would be very helpful.
Comment 7 Quality Engineering 2008-04-24 03:53:04 UTC
Issue '133639' Integrated in NB_Trunk_Production #154 : http://hg.netbeans.org/main/rev/a38a9a3078c0,
 with comment: #133639: deadlock after modifying project properties.
Comment 8 _ moser 2008-04-24 11:39:36 UTC
I will increase priority to P2 to improve the chance to get this issue being noticed as a candidate for a
patch: in 1 of 2 cases I can reproduce the deadlock on closing the module property dialog. This is more than annoying
particularly when I had unsaved files. Yesterday this issue caused me to kill and restart NB 4 times. So I started to
work around this issue by manually modifying dependencies and public packages in project.xml.
Comment 9 Jesse Glick 2008-04-24 18:19:33 UTC
Again, if the reporter is able to verify the fix (e.g. trunk build with fix does not display deadlock under similar
conditions after at least ten attempts), that would be helpful.
Comment 10 Jiri Prox 2008-04-24 20:14:33 UTC
just for information, the trunk build is available here: http://bits.netbeans.org/dev/nightly/latest/
Comment 11 _ moser 2008-04-25 11:18:06 UTC
I have tested the latest build from trunk (200804250004) and the problem seems to be fixed. Feel free to mark the issue
as verified.
Comment 12 Jesse Glick 2008-04-25 16:06:05 UTC
Great, thank you!
Comment 13 Jesse Glick 2008-04-30 19:14:38 UTC
*** Issue 134177 has been marked as a duplicate of this issue. ***
Comment 14 Tomas Danek 2008-05-05 12:02:56 UTC
IMHO candidate for 6.1 patch2
Comment 15 Jesse Glick 2008-05-06 17:17:21 UTC
*** Issue 134486 has been marked as a duplicate of this issue. ***
Comment 16 pgebauer 2008-05-29 15:59:13 UTC
The fix has been ported into the release61_fixes branch:

http://hg.netbeans.org/release61_fixes/rev/7aee0221dec9
Comment 17 Tomas Zezula 2008-06-19 14:51:11 UTC
*** Issue 135636 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo