Bug 132165 - Implement Compile on Save (Incremental Compilation)
Implement Compile on Save (Incremental Compilation)
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Compiler
6.x
All All
: P2 with 2 votes (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
http://wiki.netbeans.org/CompileOnSave
: PLAN
: 118181 (view as bug list)
Depends on: 110465
Blocks: 137828
  Show dependency treegraph
 
Reported: 2008-04-07 10:30 UTC by Jan Becicka
Modified: 2008-07-11 20:46 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Becicka 2008-04-07 10:30:12 UTC
Implement Compile on Save (Incremental Compilation)
Comment 1 Lukas Hasik 2008-04-24 09:20:15 UTC
*** Issue 118181 has been marked as a duplicate of this issue. ***
Comment 2 Jan Becicka 2008-04-25 07:49:31 UTC
Compile on Save (also known as Incremental Compilation) is highly requested feature, especially from users moving (or
want to move) from Eclipse. This feature significantly speeds up edit/compile/deploy/test cycle.

There will be a new option to turn on/off automatic building of project. Modified source will be compiled immediately
after modifications are saved. It will not be required to invoke build to be able to test the project. 
Comment 3 _ theanuradha 2008-06-10 12:19:39 UTC
Any updates on this (finger crossed)
Comment 4 Jan Becicka 2008-06-10 12:34:20 UTC
feature is planned for M2.
Comment 5 Jan Becicka 2008-07-09 12:55:56 UTC
Fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo