Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 131976 - Inconsistent selection appearance in the new project wizard in Nimbus theme - dark color on dark background
Inconsistent selection appearance in the new project wizard in Nimbus theme -...
Status: RESOLVED WONTFIX
Product: projects
Classification: Unclassified
Component: Generic Projects UI
6.x
Sun Solaris
: P4 (vote)
: TBD
Assigned To: Tomas Stupka
issues@projects
: L&F, NO74
Depends on:
Blocks: 131305
  Show dependency treegraph
 
Reported: 2008-04-03 19:25 UTC by Ondrej Langr
Modified: 2016-07-07 08:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Inconsistent appearance of selection in the new project wizard (31.08 KB, text/plain)
2008-04-03 19:26 UTC, Ondrej Langr
Details
Shows the issue "Light Nimbus" vs. "Dark Nimbus" (147.48 KB, image/png)
2013-08-18 16:54 UTC, markiewb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ondrej Langr 2008-04-03 19:25:37 UTC
The appearance of selection in the two lists in "New Project Wizard" is inconsistent. See the attached image. The proper
Nimbus solution is a selection extending all the way and white text color on the selected line.
Comment 1 Ondrej Langr 2008-04-03 19:26:59 UTC
Created attachment 59637 [details]
Inconsistent appearance of selection in the new project wizard
Comment 2 Milan Kubec 2008-04-03 19:51:34 UTC
The list on the right side looks on all L&Fs the same, so do you mean to fix the appearance on all L&Fs? The difference
is in the left list which looks special in Nimbus L&F.

Lowering priority according to Bug Priority guidelines.

Please select proper MIME type when attaching images.


Comment 3 Ondrej Langr 2008-04-04 10:07:30 UTC
Actually, the problem is with the right list, which does not change appearance to follow used L&F and thus is not
consistent with other components. Its appearance should follow used L&F, be it Nimbus, Metal or anything else. 

The current look does not follow selected L&F, so this is IMO "incorrect visual appearance" rather than "minor
annoyance". Increasing priority accordingly. 

Apologies for the incorrect MIME type, will do next time ;).
Comment 4 Ondrej Langr 2008-04-04 10:20:06 UTC
Actually, there's also an issue with the left list which makes the text color of selected line switch to black if focus
is moved to other component. Selected row in JList should (according to Nimbus spec.) have always white text
independently of where focus is. 
Comment 5 markiewb 2013-08-18 16:54:06 UTC
Created attachment 138836 [details]
Shows the issue "Light Nimbus" vs. "Dark Nimbus"
Comment 6 Marian Mirilovic 2013-08-23 13:53:16 UTC
Dark themes were moved to the NetBeans Update Center for NB 7.4
Comment 7 Martin Balin 2016-07-07 08:39:31 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo