Bug 131079 - I18N - Project properies dialog has resieze issues
I18N - Project properies dialog has resieze issues
Status: RESOLVED DUPLICATE of bug 124863
Product: projects
Classification: Unclassified
Component: Generic Projects UI
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Milan Kubec
issues@projects
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-25 19:08 UTC by kaa
Modified: 2008-03-31 08:32 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
affected categories circled in blue for RH4: Java App (79.26 KB, image/jpeg)
2008-03-25 19:10 UTC, kaa
Details
web app properties dialog on WinXP (77.10 KB, image/jpeg)
2008-03-25 19:12 UTC, kaa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaa 2008-03-25 19:08:40 UTC
Product Version: NetBeans IDE Dev (Build 200803231202)
Java: 1.6.0_05; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; MS932; ja_JP (nb)
font size 16

Steps:
1. Create Java Application
2. Open project properties dialog

The dialog does not resize to show text from several categories listed at right side.
The same for:
WebApp, EJB Module (See Build->Documenting - Additional Javadoc Options)
BPEL Module (See XML Catalog - Cache Location ).
The prblem appears not only on Windows. I checked with RH4 - the same behavior.


Assumption is that user does not need to manually resize most windows or dialogs to see all of the UI objects and
information in them. I'm running in pseudo localized locale in which each message/label is sometimes longer than in
English. To account for that in some locales, translations from English (and some other euro languages) could be shown
with longer strings.

Also I'm running at font size 16, which is viewed as a valid font size that might be used. Resizing issues are not just
related to i18n; they might show to user in English locale if they run at larger font size.

Often, these issues happen because the length of some label or message or size of entire window is hardcoded vs using
layout managers or other techniques or api to have the windows or the objects in them, dynamically resize. Sometimes,
embedding components in a scroll pane will solve the problem.
Comment 1 kaa 2008-03-25 19:10:54 UTC
Created attachment 59059 [details]
affected categories circled in blue for RH4: Java App
Comment 2 kaa 2008-03-25 19:12:18 UTC
Created attachment 59062 [details]
web app properties dialog on WinXP
Comment 3 Ken Frank 2008-03-25 23:14:56 UTC
for the first gif, under the categories section, if by using the scrollbar
at bottom of that section, all the message can then be seen, then those parts
are not an issue, since that is one of the exceptions about resizing, that
its expected user would need to use the scrollbar (but not need to resize the window
otherwise to see all its contents)

ken.frank@sun.com
Comment 4 kaa 2008-03-26 00:14:18 UTC
Ken,

all text circled in blue is not a subject for issue.
I marked so only affected categories. If you select any of them the issue will be on right side of the wizard.
The image was for JavaApp
Comment 5 Milan Kubec 2008-03-31 08:32:37 UTC
Issue with the JWS hint was already fixed, see duplicate issue. Other hint on javadoc page is in fact fully visible
there is nothing hidden, compare when running IDE with regular fonts. 

It's difficult to accept similar issues as P2 where some *hint* is partially hidden. The hint is there just to specify
what should be entered into the field, it's usually some example.

*** This issue has been marked as a duplicate of 124863 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo