Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 128288 - Impossible to add quotes in comment
Impossible to add quotes in comment
Status: RESOLVED DUPLICATE of bug 122314
Product: versioncontrol
Classification: Unclassified
Component: Subversion
6.x
All Windows XP
: P3 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-25 10:18 UTC by lforet
Modified: 2008-02-25 11:02 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lforet 2008-02-25 10:18:33 UTC
It is impossible to add quotes in a commit's comment.

Example :
correct soapmessage remove "SoapMessenger.send() endpoint ... " trace from message 

Throw this exception :
INFO: org.tigris.subversion.svnclientadapter.commandline.CmdLineException: svn: Error resolving case of '...'

org.tigris.subversion.svnclientadapter.commandline.CmdLineException: svn: Error resolving case of '...'

	at org.tigris.subversion.svnclientadapter.commandline.CommandLine.execString(CommandLine.java:195)
	at org.tigris.subversion.svnclientadapter.commandline.SvnCommandLine.checkin(SvnCommandLine.java:178)
	at org.tigris.subversion.svnclientadapter.commandline.CmdLineClientAdapter.commit(CmdLineClientAdapter.java:569)
Caused: org.tigris.subversion.svnclientadapter.SVNClientException
	at org.tigris.subversion.svnclientadapter.SVNClientException.wrapException(SVNClientException.java:87)
	at org.tigris.subversion.svnclientadapter.commandline.CmdLineClientAdapter.commit(CmdLineClientAdapter.java:592)
	at org.tigris.subversion.svnclientadapter.commandline.CmdLineClientAdapter.commit(CmdLineClientAdapter.java:556)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)
	at org.netbeans.modules.subversion.client.SvnClientInvocationHandler.handle(SvnClientInvocationHandler.java:215)
	at
org.netbeans.modules.subversion.client.SvnCmdLineClientInvocationHandler.invokeMethod(SvnCmdLineClientInvocationHandler.java:82)
	at org.netbeans.modules.subversion.client.SvnClientInvocationHandler.invoke(SvnClientInvocationHandler.java:147)
	at $Proxy12.commit(Unknown Source)
[catch] at org.netbeans.modules.subversion.ui.commit.CommitAction.performCommit(CommitAction.java:608)
	at org.netbeans.modules.subversion.ui.commit.CommitAction.performCommit(CommitAction.java:495)
	at org.netbeans.modules.subversion.ui.commit.CommitAction$3.perform(CommitAction.java:322)
	at org.netbeans.modules.subversion.client.SvnProgressSupport.performIntern(SvnProgressSupport.java:102)
	at org.netbeans.modules.subversion.client.SvnProgressSupport.run(SvnProgressSupport.java:95)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)

To make my commit successfull, I had to remove the quotes in my message.

Regards.
Comment 1 Tomas Stupka 2008-02-25 11:02:29 UTC

*** This issue has been marked as a duplicate of 122314 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo