Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 122314 - IAE when commit message contains quotation marks
IAE when commit message contains quotation marks
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
release601_fixes_candidate2, release6...
:
: 121432 128029 128288 130234 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-19 16:28 UTC by Radko Najman
Modified: 2008-03-20 18:47 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IAE (2.13 KB, text/plain)
2007-11-19 16:29 UTC, Radko Najman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Radko Najman 2007-11-19 16:28:53 UTC
The attached exception was thrown when I tried to commit with a message containing quotation marks, e.g.
  This is "my" commit message
and the commit failed.

I would propose better error handling here, e.g. warning dialog saying what was wrong.
Comment 1 Radko Najman 2007-11-19 16:29:21 UTC
Created attachment 53211 [details]
IAE
Comment 2 Peter Pis 2007-12-12 08:33:53 UTC
*** Issue 121432 has been marked as a duplicate of this issue. ***
Comment 3 Tomas Stupka 2007-12-14 14:04:57 UTC
fixed

Checking in svnClientAdapter-0.9.23.jar;
/cvs/subversion/client/external/svnClientAdapter-0.9.23.jar,v  <--  svnClientAdapter-0.9.23.jar
new revision: 1.2; previous revision: 1.1
Comment 4 Tomas Stupka 2008-02-21 21:19:33 UTC
*** Issue 128029 has been marked as a duplicate of this issue. ***
Comment 5 Tomas Stupka 2008-02-25 11:02:18 UTC
*** Issue 128288 has been marked as a duplicate of this issue. ***
Comment 6 novakm 2008-02-26 07:53:58 UTC
Verified in latest trunk build.
Comment 7 pslechta 2008-03-05 18:12:08 UTC
The fix has been ported into the release601_fixes branch.

Checking in svnClientAdapter-0.9.23.jar;
/cvs/subversion/client/external/Attic/svnClientAdapter-0.9.23.jar,v  <--  svnClientAdapter-0.9.23.jar
new revision: 1.1.6.1; previous revision: 1.1
done
Comment 8 Jana Maleckova 2008-03-13 11:26:45 UTC
verified on 
Product Version: NetBeans IDE 6.0.1 (Build 200801291616)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)
with patch 2
Comment 9 Peter Pis 2008-03-16 10:36:02 UTC
*** Issue 130234 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo