Bug 128006 - IDE freezes during work in main menu
IDE freezes during work in main menu
Status: RESOLVED WORKSFORME
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Milos Kleint
issues@projects
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-21 12:08 UTC by Jana Maleckova
Modified: 2008-03-13 10:10 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
128006 (20.38 KB, text/plain)
2008-02-21 12:09 UTC, Jana Maleckova
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jana Maleckova 2008-02-21 12:08:36 UTC
Product Version: NetBeans IDE Dev (Build 200802191203)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; Cp1252; en_GB (nb)

Description:
=============
I was working with main menu for versioning. The main structure of versioning menu was visible but I was not able to
open submenus of each types of vcs (cvs,subverion,mercurial). Not possible to reproduce. Thread dump is enclosed to this
issue
Comment 1 Jana Maleckova 2008-02-21 12:09:52 UTC
Created attachment 56977 [details]
128006
Comment 2 David Simonek 2008-02-29 10:01:44 UTC
From thread dump, I'm not able to see any deadlock, all I see is that most of the threads are waiting in Mutex,
including AWT which causes freeze. I see a lot of projects refreshing in important threads, so passing to projects,
perhaps they will know more.
Comment 3 Milos Kleint 2008-03-13 10:10:32 UTC
I can't reproduce either, the thread dump doesn't seem to indicate any deadlock or race condition. 

closing as works for me until we get some steps to reproduce.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo