Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 127601 - Add jars in vista
Add jars in vista
Status: RESOLVED DUPLICATE of bug 122577
Product: platform
Classification: Unclassified
Component: Directory Chooser
6.x
PC Windows Vista
: P3 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-18 09:49 UTC by klasgermunder
Modified: 2008-12-22 11:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description klasgermunder 2008-02-18 09:49:54 UTC
When right klicking project chosing properties --> libraries --> add JAR/Folder. The file chooser i stuck on the
destktop  until i enter a file path manually.
Comment 1 Jiri Prox 2008-02-18 10:39:42 UTC
What does it means "stuck", is the whole IDE frozen or does it take a long time directory is listed?
Does the actual directory contain a large zip file? (see issue 127603)
Comment 2 klasgermunder 2008-02-18 11:01:17 UTC
Sorry stuck means i cant navigate any where. the "my desktop" folder is shown but i cant navigate any where in the 
file chooser unless i enter a file path manualy. But when i have done that i can navigate in my file struckture.
Comment 3 David Simonek 2008-02-29 12:51:43 UTC
klasgermunder, I still quite don't understand, can you give us screen shot how it looks when you can't navigate? There
is a combo box where you can select a path...  
Comment 4 klasgermunder 2008-02-29 13:12:13 UTC
yes i discoverd the combobox so if i enter for example c:\tmp in that box i can start to navigate. But default in my 
vista installation is that it starts at "desktop" and from there you cant navigate by clicking! i have to write some 
path to be able to start to navigate by clicking.
Comment 5 klasgermunder 2008-02-29 13:12:44 UTC
yes i discoverd the combobox so if i enter for example c:\tmp in that box i can start to navigate. But default in my 
vista installation is that it starts at "desktop" and from there you cant navigate by clicking! i have to write some 
path to be able to start to navigate by clicking.
Comment 6 Denis Anisimov 2008-03-04 17:32:43 UTC
Could you please provide more details on this because I'm not sure 
what you talking about exactly.
There are at least two UI controls for navigation :
1) Combobox on the top of dialog
2) List of files under this combobox.

There is an issue #123366 that related to Combobox. May be you talking about 
this problem ? In this case this is just duplicate.

But may be you mean absence of possibility to use File List control ......
Please confirm/disclaim this.
I'm asking about this because on my Vista box navigation in File list works fine.
Please recheck.
Comment 7 David Simonek 2008-03-11 11:08:47 UTC
I think I understand it now - reporter is actually unhappy that there are no disc drives visible in combo box.
Workaround for this is 
a) to write the path like reporter did or
b) to press "directory up" button so that "My computer" is finally visible and then it is possible to drill down into
disc drives and its subdirs.

This usability flaw is already reported in 122577, so I'm making duplicate.

klasgermunder, please reopen if I'm wrong, thanks.

*** This issue has been marked as a duplicate of 122577 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo