Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 122577 - New File dialogs - accessing disc drives not possible
New File dialogs - accessing disc drives not possible
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Directory Chooser
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
:
: 123366 127601 133744 136449 146199 153049 159795 166698 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-22 11:03 UTC by Michal Skvor
Modified: 2009-06-09 10:11 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Open dialong in plugins. Completely lost ... (14.55 KB, image/png)
2007-11-22 11:05 UTC, Michal Skvor
Details
Open Project. Where are my other drives? (22.86 KB, image/png)
2007-11-22 11:07 UTC, Michal Skvor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Skvor 2007-11-22 11:03:58 UTC
The new file dialogs completely lost their primary goals and become unusable. They don't follow at least windows style
for opening files and opening of files are painful experience. 

There should be at least some kind of approach how to simply access disc drives on Windows.

See attached screenshots for details.
Comment 1 Michal Skvor 2007-11-22 11:05:24 UTC
Created attachment 53361 [details]
Open dialong in plugins. Completely lost ...
Comment 2 Michal Skvor 2007-11-22 11:07:31 UTC
Created attachment 53362 [details]
Open Project. Where are my other drives?
Comment 3 Petr Chytil 2007-11-26 13:00:18 UTC
reassigning to openide for evaluation, ok?
Comment 4 David Simonek 2008-02-25 09:50:18 UTC
What Java version etc? Can you reproduce always? Is it regression? I didn't have any problems with accessing all drives
on my Windows as far as I remember...

Second, you are probably missing "right side windows icon bar'. We had to disable it due to JDK performance bug which we
can't workaround.
Comment 5 Michal Skvor 2008-03-06 17:12:46 UTC
What I want is direct access to discs. I have my projects on different disc and when I use open dialog I see Desktop and
nothing more. So I have to use "Up directory" button to get to my computer then doubleclick on my computer to get list
of discs and then I could finally select proper directory. In previous version I was able using ComboBox directly select
disc.

Is it possible to start NetBeans with some command line parameter to have the same open dialog as in previous < 6.0
version of NetBeans?
Comment 6 David Simonek 2008-03-11 11:08:36 UTC
*** Issue 127601 has been marked as a duplicate of this issue. ***
Comment 7 David Simonek 2008-03-12 09:38:47 UTC
Understood, removing "INCOMPLETE" keyword.

Yes, cmd line param to run netbeans with awful plain swing file chooser is "-J-Dstandard-file-chooser=true"
Comment 8 Lukas Hasik 2008-04-10 21:22:20 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 9 Petr Chytil 2008-04-23 09:37:16 UTC
*** Issue 133744 has been marked as a duplicate of this issue. ***
Comment 10 Lukas Hasik 2008-06-04 11:45:55 UTC
*** Issue 136449 has been marked as a duplicate of this issue. ***
Comment 11 Lukas Hasik 2008-09-09 15:44:27 UTC
*** Issue 146199 has been marked as a duplicate of this issue. ***
Comment 12 Lukas Hasik 2008-09-09 17:24:05 UTC
*** Issue 123366 has been marked as a duplicate of this issue. ***
Comment 13 Lukas Hasik 2008-11-12 20:47:21 UTC
*** Issue 153049 has been marked as a duplicate of this issue. ***
Comment 14 pslechta 2009-02-24 14:45:13 UTC
There is escalation from the customer for this issue: bugster CR 6797031. Increasing priority of this issue to P2.

The problem is connected with workaround used to fix Issue 109703. When the workaround is commented out, the open dialog
works fine.
Comment 15 Andrei Chistiakov 2009-03-06 16:42:18 UTC
*** Issue 159795 has been marked as a duplicate of this issue. ***
Comment 16 David Simonek 2009-03-26 16:50:25 UTC
fixed in best way that I could come with.

changeset:   123410:0cdbf269e2a2
user:        Dafe Simonek <dsimonek@netbeans.org>
date:        Tue Mar 24 18:11:54 2009 +0100
summary:     #122577: enable of windows places bar with slowness checks

changeset:   123411:0d9563ac4bc8
user:        Dafe Simonek <dsimonek@netbeans.org>
date:        Wed Mar 25 09:46:12 2009 +0100
summary:     #122577: part 2, fix versions where Windows shell folder will not be used

changeset:   123412:805c7f030886
user:        Dafe Simonek <dsimonek@netbeans.org>
date:        Wed Mar 25 11:57:40 2009 +0100
summary:     #122577: part 3, further versions and timeout finetuning

changeset:   123413:a03ce0391b5a
tag:         tip
user:        Dafe Simonek <dsimonek@netbeans.org>
date:        Thu Mar 26 14:34:13 2009 +0100
summary:     #122577: part 4, automatic measuring of file chooser slowness, warning message

changeset:   123837:f3626eb39c7a
tag:         tip
user:        Dafe Simonek <dsimonek@netbeans.org>
date:        Thu Mar 26 14:52:03 2009 +0100
summary:     #122577: part 5, adjust timeout to final value

What the fix does:
- adds boolean system property "nb.FileChooser.useShellFolder" to force enabling or disabling of windows places bar
- windows places bar is now disabled by default only in JDK version interval <1.6.0_02, 1.6.0_10>
- automatic checking of dialog slowness was added, with warning/help message if some timeout is exceeded

As behavior is quite varied, I documented it a bit in NB Users FAQ:

http://wiki.netbeans.org/FaqWindowsPlacesBar
http://wiki.netbeans.org/FaqWindowsCPU
Comment 17 Quality Engineering 2009-03-28 20:39:19 UTC
Integrated into 'main-golden', will be available in build *200903281400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/0cdbf269e2a2
User: Dafe Simonek <dsimonek@netbeans.org>
Log: #122577: enable of windows places bar with slowness checks
Comment 18 David Simonek 2009-06-09 10:11:02 UTC
*** Issue 166698 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo