Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 127565 - java.io.IOException: Cannot run program "cleartool": java.io.IOException: error=2, No such file or directory
java.io.IOException: Cannot run program "cleartool": java.io.IOException: err...
Status: CLOSED FIXED
Product: versioncontrol
Classification: Unclassified
Component: ClearCase
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 158719 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-16 23:04 UTC by Marian Mirilovic
Modified: 2009-02-18 13:28 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.85 KB, text/plain)
2008-02-16 23:04 UTC, Marian Mirilovic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2008-02-16 23:04:12 UTC
Build: NetBeans IDE Dev (Build 200802140010)
VM: Java HotSpot(TM) Client VM, 10.0-b19
OS: Linux, 2.6.12-10-686, i386

User Comments: 
I don't have installed CC. Pushed main CC menu Update
Comment 1 Marian Mirilovic 2008-02-16 23:04:19 UTC
Created attachment 56780 [details]
stacktrace
Comment 2 Marian Mirilovic 2008-02-16 23:09:28 UTC
The same exception for :
Browse History
Browse Version Tree
Show Properties

These menus should be disabled or at least show dialog and ask for location of cleartool.
Comment 3 Tomas Stupka 2008-02-17 15:16:06 UTC
where does your CC plugin come from - a NB update center or did you build it from sources?
Comment 4 Maros Sandor 2008-02-18 08:53:03 UTC
I have fixed this recently so that users without CC are not bothered with exceptions at all. Please verify in latest builds.
25eb07eab643
Comment 5 Tomas Stupka 2008-02-18 10:00:30 UTC
Browse History
Browse Version Tree
Show Properties

still throws exception

diff should be disabled
Comment 6 Maros Sandor 2008-02-18 11:24:30 UTC
916677805251
Comment 7 Marian Mirilovic 2008-06-18 11:16:19 UTC
verified
Comment 8 Ondrej Vrabec 2009-02-18 13:28:04 UTC
*** Issue 158719 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo