Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 158719 - org.netbeans.modules.clearcase.ClearcaseUnavailableException: java.io.IOException: Cannot run program "cleartool": CreateProcess error=2, The system cannot find the file specified
org.netbeans.modules.clearcase.ClearcaseUnavailableException: java.io.IOExcep...
Status: CLOSED DUPLICATE of bug 127565
Product: versioncontrol
Classification: Unclassified
Component: ClearCase
6.x
All Windows XP
: P2 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 11:48 UTC by Marian Mirilovic
Modified: 2009-12-03 03:25 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2009-02-18 11:48:21 UTC
78 duplicates so far ...

Build: NetBeans IDE 6.1 (Build 200804211638)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_05-b13
OS: Windows Vista, 6.0, x86
User comments: updating new plugins
STACKTRACE: (first 10 lines)
org.netbeans.modules.clearcase.ClearcaseUnavailableException: java.io.IOException: Cannot run program "cleartool":
CreateProcess error=2, The system cannot find the file specified
        at org.netbeans.modules.clearcase.client.ClearcaseClient.ensureCleartool(ClearcaseClient.java:373)
        at org.netbeans.modules.clearcase.client.ClearcaseClient.access$000(ClearcaseClient.java:73)
        at org.netbeans.modules.clearcase.client.ClearcaseClient$CommandRunnable.run(ClearcaseClient.java:196)
        at org.netbeans.modules.clearcase.client.ClearcaseClient.execImpl(ClearcaseClient.java:145)
        at org.netbeans.modules.clearcase.client.ClearcaseClient.exec(ClearcaseClient.java:125)
        at org.netbeans.modules.clearcase.client.ClearcaseClient.exec(ClearcaseClient.java:115)
        at org.netbeans.modules.clearcase.Clearcase.getTopmostManagedParent(Clearcase.java:257)
        at org.netbeans.modules.clearcase.ClearcaseVCS.getTopmostManagedAncestor(ClearcaseVCS.java:87)
        at org.netbeans.modules.versioning.VersioningManager.getOwner(VersioningManager.java:240)
        at org.netbeans.modules.versioning.FilesystemInterceptor.getInterceptor(FilesystemInterceptor.java:252)
Comment 1 Ondrej Vrabec 2009-02-18 13:28:14 UTC
Issue appears when CC is not installed.

*** This issue has been marked as a duplicate of 127565 ***
Comment 2 Marian Mirilovic 2009-12-03 03:25:46 UTC
v/c


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo