Bug 127539 - Create new MySQL node
Create new MySQL node
Status: RESOLVED FIXED
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: 6.x
Assigned To: David Vancouvering
issues@db
http://wiki.netbeans.org/MySQLNodeUISpec
: PLAN, UI
: 122191 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-16 10:16 UTC by David Vancouvering
Modified: 2008-02-25 07:36 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Vancouvering 2008-02-16 10:16:18 UTC
Create a new node for a MySQL server under Databases.  This will provide basic management features such as view all
databases, connect to a database, create a new (potentially sample) database, and bring up the administrative tool.

This node is automatically added if a local MySQL server is detected.  Otherwise the user can manually register the node.
Comment 1 David Vancouvering 2008-02-17 06:11:26 UTC
*** Issue 122191 has been marked as a duplicate of this issue. ***
Comment 3 David Vancouvering 2008-02-24 08:28:44 UTC
Another incremental checkin: Start, Stop, Admin features

http://hg.netbeans.org/main?cmd=changeset;node=cb5fe3f7f369
Comment 4 David Vancouvering 2008-02-25 07:36:08 UTC
Final commits to make this feature complete for 6.1.  This provides auto-detection of some standard installations on
Windows, Mac and Linux, where it is useful to detect (for purposes of start, stop, and administer).

I am sure more enhancements to come in 6.next, this will be tracked by subsequent issues.

http://hg.netbeans.org/main?cmd=changeset;node=8329fa217fff
http://hg.netbeans.org/main?cmd=changeset;node=42c7b24fadff


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo