Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 127259 - IOE when opening a NB module
IOE when opening a NB module
Status: RESOLVED DUPLICATE of bug 126954
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P2 (vote)
: TBD
Assigned To: issues@ide
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-13 07:32 UTC by Tomasz Slota
Modified: 2008-02-22 16:55 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Full IDE log (81.69 KB, text/plain)
2008-02-13 07:34 UTC, Tomasz Slota
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomasz Slota 2008-02-13 07:32:47 UTC
I keep getting an IOE when trying to open and debug a NB module project. Debugging doesn't work as the source roots are not found.

java.io.IOException: Not an NBM project in /Users/tomslot/SUN/src/js2/javascript2/core
	at org.netbeans.modules.apisupport.project.universe.ModuleList$1.run(ModuleList.java:161)
	at org.netbeans.modules.apisupport.project.universe.ModuleList$1.run(ModuleList.java:153)
	at org.openide.util.Mutex.readAccess(Mutex.java:291)
	at org.netbeans.modules.apisupport.project.universe.ModuleList.getModuleList(ModuleList.java:152)
	at org.netbeans.modules.apisupport.project.universe.ModuleList.getModuleList(ModuleList.java:136)
	at org.netbeans.modules.apisupport.project.universe.TestEntry.getNetBeansOrgPath(TestEntry.java:187)
	at org.netbeans.modules.apisupport.project.universe.TestEntry.getSrcDir(TestEntry.java:139)
	at org.netbeans.modules.apisupport.project.queries.GlobalSourceForBinaryImpl.findSourceRoots(
Comment 1 Tomasz Slota 2008-02-13 07:34:56 UTC
Created attachment 56572 [details]
Full IDE log
Comment 2 Jiri Vagner 2008-02-22 16:55:11 UTC

*** This issue has been marked as a duplicate of 126954 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo