Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 126954 - IO Exception opening netbeans module projects from netbeans mercurial repo
IO Exception opening netbeans module projects from netbeans mercurial repo
Status: RESOLVED DUPLICATE of bug 126135
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All Windows XP
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@apisupport
:
: 127259 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-07 23:17 UTC by Srinivasan Chikkala
Modified: 2008-02-22 16:55 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Srinivasan Chikkala 2008-02-07 23:17:01 UTC
Got the following ioexception when I opened xml.retriever project from netbeans mercurial repo

java.io.IOException: Not an NBM project in C:\home\chikkala\dev\nb\main\nb_all\main\core
	at org.netbeans.modules.apisupport.project.universe.ModuleList$1.run(ModuleList.java:161)
	at org.netbeans.modules.apisupport.project.universe.ModuleList$1.run(ModuleList.java:153)
	at org.openide.util.Mutex.readAccess(Mutex.java:291)
	at org.netbeans.modules.apisupport.project.universe.ModuleList.getModuleList(ModuleList.java:152)
	at org.netbeans.modules.apisupport.project.universe.ModuleList.getModuleList(ModuleList.java:136)
	at org.netbeans.modules.apisupport.project.universe.TestEntry.getNetBeansOrgPath(TestEntry.java:187)
	at org.netbeans.modules.apisupport.project.universe.TestEntry.getSrcDir(TestEntry.java:139)
	at org.netbeans.modules.apisupport.project.universe.TestEntry.getProject(TestEntry.java:207)
	at
org.netbeans.modules.apisupport.project.queries.UpdateTrackingFileOwnerQuery.getOwner(UpdateTrackingFileOwnerQuery.java:110)
	at
org.netbeans.modules.apisupport.project.queries.UpdateTrackingFileOwnerQuery.getOwner(UpdateTrackingFileOwnerQuery.java:72)
	at org.netbeans.api.project.FileOwnerQuery.getOwner(FileOwnerQuery.java:147)
	at org.netbeans.modules.java.project.JavadocForBinaryQueryImpl.findJavadoc(JavadocForBinaryQueryImpl.java:67)
	at org.netbeans.api.java.queries.JavadocForBinaryQuery.findJavadoc(JavadocForBinaryQuery.java:85)
	at org.netbeans.modules.javadoc.search.JavadocRegistry.readRoots(JavadocRegistry.java:172)
	at org.netbeans.modules.javadoc.search.JavadocRegistry.getDocRoots(JavadocRegistry.java:127)
	at org.netbeans.modules.javadoc.search.IndexBuilder.refreshIndex(IndexBuilder.java:194)
	at org.netbeans.modules.javadoc.search.IndexBuilder.run(IndexBuilder.java:122)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:561)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:986)
Comment 1 Jesse Glick 2008-02-08 00:38:07 UTC
You need to use a dev build if you want to work on modules in the Hg repo.

*** This issue has been marked as a duplicate of 126135 ***
Comment 2 Jiri Vagner 2008-02-22 16:55:11 UTC
*** Issue 127259 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo