Bug 125970 - NB6.0.1 "Build JNLP Application" fails around jarsigner on Windows using ml release
NB6.0.1 "Build JNLP Application" fails around jarsigner on Windows using ml r...
Status: VERIFIED FIXED
Product: apisupport
Classification: Unclassified
Component: Harness
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Jesse Glick
issues@apisupport
release601_fixes_candidate1 release60...
: I18N
: 127105 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-25 03:54 UTC by Masaki Katakai
Modified: 2008-02-20 18:17 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Possible patch (untested by me) (652 bytes, patch)
2008-01-25 09:36 UTC, Jesse Glick
Details | Diff
Replacement for harness/tasks.jar including patch (412.64 KB, application/octet-stream)
2008-01-28 17:05 UTC, Jesse Glick
Details
error msg from jnlp build (1.63 KB, text/plain)
2008-01-28 18:12 UTC, Ken Frank
Details
Replacement tasks.jar with corrected task (412.65 KB, application/octet-stream)
2008-01-28 18:59 UTC, Jesse Glick
Details
message (656 bytes, text/plain)
2008-01-28 20:34 UTC, Ken Frank
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Masaki Katakai 2008-01-25 03:54:22 UTC
Product Version: NetBeans IDE 6.0.1 (Build 200801231200)
Java: 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19
System: Windows XP version 5.1 running on x86; MS932; en (nb)

Build JNLP Application fails in ml build only on Windows. It didn't happen on English NetBeans 6.0
and ML NetBeans 5.5.1, also it works in other platform. I verified Solaris and Linux work fine.

1. Start NB
2. Create sample app of NetBeans module e.g. Paint App
3. Run to run "Build JNLP Application"

It fails with the following error.

jnlp-generate-platform-repository:
Signing JAR: C:\Program Files\NetBeans 6.0.1\platform7\core\locale\core_pt_BR.jar to C:\Documents and
Settings\katakai\My
Documents\NetBeansProjects\PaintApp2\build\jnlp\netbeans\org-netbeans-core-startup\locale\core_pt_BR.jar as jnlp
jarsigner: [can not create] : C:\Documents and Settings\katakai\My
Documents\NetBeansProjects\PaintApp2\build\jnlp\netbeans\org-netbeans-core-startup\locale\core_pt_BR.jar
[enter password for keystore:]
C:\Program Files\NetBeans 6.0.1\harness\suite.xml:342: The following error occurred while executing this line:
C:\Program Files\NetBeans 6.0.1\harness\jnlp.xml:172: jarsigner returned: 1
BUILD FAILED (total time: 3 seconds)

I think it will also fail on English environment, so it's not just ml issue, it will be critical for all developer.
Can anyone try it on *pure* English environment? I tried it with --locale en option on Japanese Windows.
Comment 1 Jesse Glick 2008-01-25 09:35:23 UTC
Probably it will work if you manually create the directory

C:\Documents and Settings\katakai\My
Documents\NetBeansProjects\PaintApp2\build\jnlp\netbeans\org-netbeans-core-startup\locale

Try that and let me know if it works.
Comment 2 Jesse Glick 2008-01-25 09:36:40 UTC
Created attachment 55554 [details]
Possible patch (untested by me)
Comment 3 Ken Frank 2008-01-25 21:23:20 UTC
removing the i18n from summary since happens even in en locale on windows
when using ml release - in this experiment the error was on the _ja.jar file
rather than pt_BR one.

Will route to QE team to see if this is viewed as showstopper for 6.0.1
since this is filed as p1.

ken.frank@sun.com
Comment 4 Marian Mirilovic 2008-01-27 21:57:39 UTC
I would say very annoying for people using NB 6.0.1, works fine for NB 6.0 (even after update). 
Creating directory "locale" in specific directory helps, at least manually. 
Comment 5 Lukas Hasik 2008-01-28 09:57:48 UTC
really painfull workaround - add the locale directory to every directory where the build fails -> downgrading to P2 (not
stopper for 6.0.1) but the fix should be provided in the patch1 for the 6.0.1

Jesse, please fix in trunk asap
Comment 6 Jesse Glick 2008-01-28 14:21:53 UTC
Can someone who has already reproduced it please check if the supplied patch works or not?
Comment 7 Jesse Glick 2008-01-28 17:05:45 UTC
Created attachment 55659 [details]
Replacement for harness/tasks.jar including patch
Comment 8 Ken Frank 2008-01-28 18:11:05 UTC
using patched harness.jar on windows, en xp and using ja regional settings also:

many jars appear to be built and signed, both en ones and localized ones;
the build stops with attached error message on not finding org-jdesktop-layout.jar file,
so its not known if all jars are built since there might be some needed
to be after that one.

ken.frank@sun.com
Comment 9 Ken Frank 2008-01-28 18:12:24 UTC
Created attachment 55667 [details]
error msg from jnlp build
Comment 10 Ken Frank 2008-01-28 18:38:40 UTC
I see the org-jdesktop-layout jars being built in build/jnlp but the error msg attached does refer
to that jar.

ken.frank@sun.com
Comment 11 Jesse Glick 2008-01-28 18:58:15 UTC
Sorry, patch was bad. Better fix in 3b80aed04040.
Comment 12 Jesse Glick 2008-01-28 18:59:36 UTC
Created attachment 55670 [details]
Replacement tasks.jar with corrected task
Comment 13 Ken Frank 2008-01-28 20:33:52 UTC
the task still fails with slightly different msg about URI syntax exception - see attached
jnlpmsg2.txt

ken.frank@sun.com
Comment 14 Ken Frank 2008-01-28 20:34:23 UTC
Created attachment 55674 [details]
message
Comment 15 Jesse Glick 2008-01-28 21:48:28 UTC
href='org-jdesktop-layout/locale\org-jdesktop-layout_pt_BR.jar' is likely some unrelated Windows-specific bug which
should be filed separately.
Comment 16 Ken Frank 2008-01-29 01:18:00 UTC
filed 126160 as per Jesse's suggestion, on the situation related to attachment
jnlpmsg2.txt

ken.frank@sun.com
Comment 17 Marian Mirilovic 2008-01-30 17:07:10 UTC
based on comments from issue 126160 - verified
Comment 18 Marian Mirilovic 2008-02-11 12:57:41 UTC
*** Issue 127105 has been marked as a duplicate of this issue. ***
Comment 19 Karthikeyan Rajeswaran 2008-02-11 21:06:50 UTC
The fix has been ported into the release601_fixes branch.

Checking in antsrc/org/netbeans/nbbuild/MakeJNLP.java;
/cvs/nbbuild/antsrc/org/netbeans/nbbuild/Attic/MakeJNLP.java,v  <--  MakeJNLP.java
new revision: 1.27.12.1; previous revision: 1.27
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo