Bug 125956 - Removing Visual JSF Patch removes ALL libraries
Removing Visual JSF Patch removes ALL libraries
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Libraries
6.x
Macintosh All
: P1 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@projects
release601_fixes_candidate1 release60...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-24 21:31 UTC by David Botterill
Modified: 2008-02-20 18:02 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Steps to reproduce (357.74 KB, application/pdf)
2008-01-24 21:33 UTC, David Botterill
Details
messages.log (170.45 KB, text/plain)
2008-01-25 00:26 UTC, David Botterill
Details
Visual JSF patch NBM (17.71 KB, application/octet-stream)
2008-01-25 18:14 UTC, David Botterill
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Botterill 2008-01-24 21:31:54 UTC
When I install the "Visual JSF" patch (1.0.2) then uninstall it, all the libraries are removed.  Please see the
attachment for details on reproducing.
Comment 1 David Botterill 2008-01-24 21:33:12 UTC
Created attachment 55530 [details]
Steps to reproduce
Comment 2 Jesse Glick 2008-01-25 00:09:00 UTC
Please attach the actual exception (or your log file).
Comment 3 David Botterill 2008-01-25 00:26:01 UTC
Created attachment 55543 [details]
messages.log
Comment 4 David Botterill 2008-01-25 00:29:01 UTC
I don't consider reinstalling a workaround so I'm changing this back to a P1 according to
http://qa.netbeans.org/bugzilla/bug_priority_guidelines.html.
Comment 5 Tomas Zezula 2008-01-25 07:41:37 UTC
There is much easier workaround, just delete ${nbuserdir}/org-netbeans-api-project-libraries/Libraries/ folder. 
From the log it seems that the JSF patch modifies even existing j2se libraries and adds an additional volume which is
unknown for j2se libraries, really nice pattern to modify someone else files.

SEVERE: java.lang.IllegalArgumentException: Volume 'runtime' is not support by this library. The only acceptable values
are: [classpath, javadoc, maven-pom, src]
org.openide.ErrorManager$AnnException: From
nbfs://nbhost/SystemFileSystem/org-netbeans-api-project-libraries/Libraries/junit-4.1.xml
Comment 6 Tomas Zezula 2008-01-25 10:17:06 UTC
Checking in org/netbeans/modules/project/libraries/LibraryDeclarationHandlerImpl.java;
/cvs/projects/libraries/src/org/netbeans/modules/project/libraries/LibraryDeclarationHandlerImpl.java,v  <-- 
LibraryDeclarationHandlerImpl.java
new revision: 1.10; previous revision: 1.9
done
Comment 7 Tomas Zezula 2008-01-25 10:21:25 UTC
The problem was that after uninstallation of the patch the libraries installed by this patch were not removed but the
libraries type (module handling them) was uninstalled.
Fixed.
Comment 8 Tomas Zezula 2008-01-25 10:39:35 UTC
To reporter: Can you verify the fix, it seems to me as a really serious problem which makes the IDE unusable, the fix is
part of the hudson build 5400 (http://deadlock.netbeans.org/hudson/job/trunk/5400/) or later.
Thank you for this report.
Comment 9 David Botterill 2008-01-25 18:13:57 UTC
If I try to install the same rogue patch, the IDE tells me it's already installed because it's named the same as the
"Visual JSF" plugin.  How else can I verify this?  I looked at the NBM file for the patch and it doesn't seem to do very
much.  I'll attach that file as well and perhaps you know how to use it for verification.
Comment 10 David Botterill 2008-01-25 18:14:55 UTC
Created attachment 55582 [details]
Visual JSF patch NBM
Comment 11 Tomas Zezula 2008-01-26 07:56:51 UTC
Thanks for the patch, I will test it and let you know.
T.
Comment 12 Tomas Zezula 2008-01-26 09:50:44 UTC
Works fine, I wasn't able to use the patch, but I did the same by hand.
1) Started basic IDE and add Visual JSF using AutoUpdate
2) After restart new libraries provided by Visual JSF appeared in the IDE
3) I've modified some of them to let IDE to rewrite them into user dir, this are not deleted by uninstall.
4) I've uninstalled the Visual JSF
5) After restart of the IDE the Visual JSF libraries were uninstalled but the rest of the libraries (j2se) were
available and working fine.

Comment 13 Marian Mirilovic 2008-01-28 10:57:27 UTC
This is a good candidate for NB 6.0.1 patch 1 - David/Tomas : agree/disagree ?
Comment 14 Tomas Zezula 2008-01-28 13:09:43 UTC
Yes
Comment 15 David Botterill 2008-01-28 13:45:31 UTC
Agree.
Comment 16 Marian Mirilovic 2008-01-30 16:56:02 UTC
OK, we will include it into Patch 1 : David could you verify the fix ?
Comment 17 David Botterill 2008-01-30 17:29:50 UTC
Yes I can verifiy the fix if I'm pointed to Patch 1 to bring my NetBeans version up to 6.0.1 so Tomas' fix is included.
Comment 18 Marian Mirilovic 2008-01-30 17:33:42 UTC
Thanks David.
Comment 19 Karthikeyan Rajeswaran 2008-02-11 02:59:09 UTC
The fix has been ported into the release601_fixes branch.

Checking in LibraryDeclarationHandlerImpl.java;
/cvs/projects/libraries/src/org/netbeans/modules/project/libraries/Attic/LibraryDeclarationHandlerImpl.java,v  <-- 
LibraryDeclarationHandlerImpl.java
new revision: 1.9.12.1; previous revision: 1.9
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo