Bug 125231 - AssertionError at org.netbeans.spi.project.support.ant.ProjectProperties$PP.write
AssertionError at org.netbeans.spi.project.support.ant.ProjectProperties$PP.w...
Status: RESOLVED DUPLICATE of bug 128618
Product: projects
Classification: Unclassified
Component: Ant Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: David Konecny
issues@projects
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: RANDOM, THREAD
: 125722 128640 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-14 16:36 UTC by Roman Mostyka
Modified: 2008-12-03 14:16 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.25 KB, text/plain)
2008-01-14 16:36 UTC, Roman Mostyka
Details
stacktrace (3.25 KB, text/plain)
2008-02-14 15:30 UTC, Dan Kolar
Details
stacktrace (4.21 KB, text/plain)
2008-02-20 19:18 UTC, _ krystyna
Details
stacktrace (3.25 KB, text/plain)
2008-02-21 02:40 UTC, _ krystyna
Details
log form au. test (33.62 KB, text/plain)
2008-03-06 12:51 UTC, Milan Kubec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Mostyka 2008-01-14 16:36:12 UTC
Build: NetBeans IDE Dev (Build 200801140000)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows XP, 5.1, x86

User Comments: 
1. Create web application with "Visual Web JSF" framework.
2. Add Table component to the page.
3. Create second web application with "Visual Web JSF" framework.

Result: AssertionError arises. This error isn't permanently reproducible.
Comment 1 Roman Mostyka 2008-01-14 16:36:16 UTC
Created attachment 55041 [details]
stacktrace
Comment 2 Dan Kolar 2008-02-14 15:30:32 UTC
Build: NetBeans IDE Dev (Build 080213)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b02
OS: Windows XP, 5.1, x86

User Comments: 
Exception fired upon creating New web project, glassfish v2, J2EE5
Comment 3 Dan Kolar 2008-02-14 15:30:36 UTC
Created attachment 56687 [details]
stacktrace
Comment 4 _ krystyna 2008-02-20 19:18:48 UTC
Build: NetBeans IDE Dev (Build 20080220164859)
VM: Java HotSpot(TM) Client VM, 10.0-b19
OS: Windows XP, 5.1, x86

User Comments: 
-first project creation after unzip/installation of this zip build.
-made it Unshared, then hit Back to set project to 1.4 from the default.
(VW Project). The VW backward compatibility kit was installed already.
Comment 5 _ krystyna 2008-02-20 19:18:54 UTC
Created attachment 56941 [details]
stacktrace
Comment 6 _ krystyna 2008-02-21 02:40:00 UTC
Build: NetBeans IDE Dev (Build 20080220164859)
VM: Java HotSpot(TM) Client VM, 10.0-b19
OS: Windows XP, 5.1, x86

User Comments: 
-creating vw web project, just added the VW JavaServerFaces framework
Comment 7 _ krystyna 2008-02-21 02:40:04 UTC
Created attachment 56957 [details]
stacktrace
Comment 8 Tomas Mysik 2008-02-22 14:12:52 UTC
Same problem in unit tests of EAR project.
Comment 9 Tomas Mysik 2008-02-22 14:13:10 UTC
*** Issue 125722 has been marked as a duplicate of this issue. ***
Comment 10 Milan Kubec 2008-02-28 07:24:14 UTC
*** Issue 128640 has been marked as a duplicate of this issue. ***
Comment 11 Milan Kubec 2008-03-06 08:49:01 UTC
Lowering back to P3, since I'm not able to reproduce. I tried two platforms, automated tests and no success.
Comment 12 Milan Kubec 2008-03-06 12:50:58 UTC
Davide, please take a look at this issue. It might be caused by recent changes in
j2ee.common.project.classpath.ClassPathModifier

I'm attaching log with debugging thread dumps from automated test from Martin Schovanek from some older build where it
was possible to reproduce. Now it doesn't seems to be reproducible, so I assume it could be fixed by other changes done
in the class most recently.
Comment 13 Milan Kubec 2008-03-06 12:51:38 UTC
Created attachment 57869 [details]
log form au. test
Comment 14 Milan Kubec 2008-03-06 12:52:32 UTC
Milos did also some recent changes to this class - adding to CC list.
Comment 15 David Konecny 2008-03-06 19:13:20 UTC
This has been fixed recently and should be fine on newer builds. 

*** This issue has been marked as a duplicate of 128618 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo