Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 124679 - Setting 'No indentation engine' does not work for HTML files
Setting 'No indentation engine' does not work for HTML files
Status: CLOSED WONTFIX
Product: web
Classification: Unclassified
Component: HTML Editor
6.x
Sun All
: P4 (vote)
: 6.x
Assigned To: Marek Fukala
Jindrich Sedek
http://www.netbeans.org/servlets/Brow...
:
: 129157 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-04 01:24 UTC by Karthikeyan Rajeswaran
Modified: 2009-05-18 10:47 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karthikeyan Rajeswaran 2008-01-04 01:24:24 UTC
To reproduce the problem, create a webapp and create an heml file in it. Open 'tools | options | advanced options |
editor settings | html editor' and set 'Indentation Engine' to 'No indentation'. Now try entering '<table>ENTER<tr>' and
the editor will still try to auto indent.

This problem also appears with RHTML files in ruby and rails projects, presumably because RHTML editor is based on HTML
editor.
Comment 1 Vitezslav Stejskal 2008-01-07 12:25:30 UTC
Umm, why do you need 'No indentation' in the first place?
Comment 2 Karthikeyan Rajeswaran 2008-01-07 14:19:34 UTC
If HTML editor does not support 'No Indentation' then the option should be removed from the advanced options for html files.

This issue was created in response to:
http://www.netbeans.org/servlets/BrowseList?list=nbusers&by=thread&from=825996
The user was annoyed with the default indentation and as a workaround wanted to switch off the indentation.

I guess it is okay to say 'No indentation' is not supported, provided it is documented and the option is removed; even
though providing the choice and accepting it is probably better. (Such an option would let the user turn off the
indentation while typing and then turn it back on and do right-click|format. By the way, this is the way java editor
works; it is possible to turn the indentation engine on and off...)

I am reopening the bug.

Please change the summary to 'Remove no-indentation from advanced options for html files' if no indentation is not
supported for html files. (I will open a separate bug for the indentation bug filed in thread 825996.

Comment 3 Vitezslav Stejskal 2008-01-08 09:51:12 UTC
Ok, the option should obviously work. Just keep in mind that 'Editor Settings' and 'Indentation Engines' as well as the
rest of the Advanced Options dialog is going to be removed.
Comment 4 Marek Fukala 2008-02-26 11:18:14 UTC
minor issue, will be fixed by removal of the advanced options.
Comment 5 Jiri Prox 2008-03-04 15:46:58 UTC
*** Issue 129157 has been marked as a duplicate of this issue. ***
Comment 6 Petr Dvorak 2008-03-04 16:06:46 UTC
There is more options in the Advanced Options that does not work properly. For example if you go to Editing > Editor
Settings > Java Editor > ellipsis (...) button by the Indentation engine in the Properties window. a window appears. If
you check/uncheck "Add newline before the brace", it has no effect - the result is always:

while (true) {
  // some code
}

instead of (in the case that a newline should be added):

while
{
  // some code
}
Comment 7 Vitezslav Stejskal 2008-03-05 10:36:36 UTC
The previous comment was reported as issue #129166.
Comment 8 pslechta 2008-10-24 11:54:10 UTC
NB 6.5: Advanced options were removed, so it is not possible to reproduce the problem.
In project properties, there is section Formatting, but in web project, I can select only "All languages" or "Java", so
no special settings for HTML files...

Closing as WONTFIX, because the described functionality is not there anymore.
Reporter, please reopen with new info if you don't agree.
Comment 9 Karthikeyan Rajeswaran 2009-01-09 18:38:53 UTC
v


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo