Bug 123715 - Editor does not work
Editor does not work
Status: RESOLVED DUPLICATE of bug 121854
Product: editor
Classification: Unclassified
Component: -- Other --
6.x
Other Windows XP
: P1 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-10 05:18 UTC by nick756
Modified: 2007-12-10 20:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nick756 2007-12-10 05:18:46 UTC
On trying to open any file in any project in newly installed NetBeans 6.0 error message "A java.lang.ClassCastException
exception has occurred." appeared. It is not possible to even view existing Java (and other) files, neither for
existing, nor for newly created projects.
Comment 1 Jiri Prox 2007-12-10 08:02:53 UTC
Please, provide a stacktrace of the exception.
Comment 2 nick756 2007-12-10 08:24:12 UTC
java.lang.ClassCastException: org.openide.filesystems.MultiFileObject$VoidValue
	at org.netbeans.modules.editor.settings.storage.EditorSettingsImpl.getCurrentFontColorProfile
(EditorSettingsImpl.java:233)
	at org.netbeans.modules.editor.settings.storage.SettingsProvider$MyLookup.<init>(SettingsProvider.java:155)
	at org.netbeans.modules.editor.settings.storage.SettingsProvider$MyLookup.<init>(SettingsProvider.java:145)
	at org.netbeans.modules.editor.settings.storage.SettingsProvider.getLookup(SettingsProvider.java:120)
	at org.netbeans.modules.editor.mimelookup.MimePathLookup.rebuild(MimePathLookup.java:101)
	at org.netbeans.modules.editor.mimelookup.MimePathLookup.<init>(MimePathLookup.java:89)
	at org.netbeans.api.editor.mimelookup.MimePath.getLookup(MimePath.java:509)
	at org.netbeans.api.editor.mimelookup.MimeLookup.getLookup(MimeLookup.java:112)
	at org.openide.text.CloneableEditorSupport.getEditorKit(CloneableEditorSupport.java:1561)
[catch] at org.netbeans.modules.web.core.JspEditorWarmUpTask.run(JspEditorWarmUpTask.java:177)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
	at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 3 Vitezslav Stejskal 2007-12-10 20:16:33 UTC
It looks like a problem with settings imported from Nb 5.x. Please try using a fresh userdir. You can do that for
example by passing '--userdir /tmp/whatever-folder-you-like' when launching Netbeans. Thanks

*** This issue has been marked as a duplicate of 121854 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo