Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 121854 - ClassCastException: org.openide.filesystems.MultiFileObject$VoidValue cannot be cast to java.lang.String
ClassCastException: org.openide.filesystems.MultiFileObject$VoidValue cannot ...
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Settings
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
http://statistics.netbeans.org/except...
release601_fixes_candidate2, release6...
:
: 123641 123715 132833 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 21:20 UTC by zwanna
Modified: 2008-04-22 02:35 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.36 KB, text/plain)
2007-12-18 20:47 UTC, leizzer
Details
stacktrace (3.87 KB, text/plain)
2007-12-27 14:24 UTC, aanno
Details
stacktrace (3.60 KB, text/plain)
2007-12-27 14:36 UTC, aannoaanno
Details
stacktrace (3.86 KB, text/plain)
2007-12-27 14:37 UTC, aannoaanno
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zwanna 2007-11-13 21:20:55 UTC
Build: NetBeans IDE Dev (Build 200710010000)
VM: Java HotSpot(TM) Client VM, 1.6.0-b105
OS: Windows XP, 5.1, x86
User comments: In the Projects window, right click on a project node and select Build ends with this ClassCastException. 
The same is reported while Netbeans launches.
STACKTRACE: (first 10 lines)
java.lang.ClassCastException: org.openide.filesystems.MultiFileObject$VoidValue cannot be cast to java.lang.String
        at
org.netbeans.modules.editor.settings.storage.EditorSettingsImpl.getCurrentFontColorProfile(EditorSettingsImpl.java:211)
        at org.netbeans.modules.editor.settings.storage.SettingsProvider$MyLookup.<init>(SettingsProvider.java:138)
        at org.netbeans.modules.editor.settings.storage.SettingsProvider$MyLookup.<init>(SettingsProvider.java:127)
        at org.netbeans.modules.editor.settings.storage.SettingsProvider.getLookup(SettingsProvider.java:101)
        at org.netbeans.modules.editor.mimelookup.MimePathLookup.rebuild(MimePathLookup.java:71)
        at org.netbeans.modules.editor.mimelookup.MimePathLookup.<init>(MimePathLookup.java:60)
        at org.netbeans.api.editor.mimelookup.MimePath.getLookup(MimePath.java:486)
        at org.netbeans.api.editor.mimelookup.MimeLookup.getLookup(MimeLookup.java:90)
        at org.openide.text.CloneableEditorSupport.getEditorKit(CloneableEditorSupport.java:1527)
        at org.netbeans.modules.uihandler.SubmitPanel.<init>(SubmitPanel.java:77)
Comment 1 Vitezslav Stejskal 2007-11-14 11:00:35 UTC
I'm not sure why we get MultiFileObject$VoidValue instead of String or null when reading a folder attribute. Maybe Radek
would know. I can workaround this in EditorSettingsImpl. In the meantime you should be able to resolve the problem by
using a fresh userdir. Just pass --userdir /path/to/your/new/fresh/userdir on commandline when launching the IDE.
Comment 2 Vitezslav Stejskal 2007-11-15 10:50:00 UTC
From Anthony Van der Zwan by email:
This bug happens after an clean install off  6.0rc1 (but not when 5.5 is on the same machine...)

---

Please do not reply to email notifications sent out by IssueZilla, your reply will not be recorded. Click on the issue
link in the email, log in and add your comments to the issue. Thanks
Comment 3 Karthikeyan Rajeswaran 2007-12-07 21:51:33 UTC
*** Issue 123641 has been marked as a duplicate of this issue. ***
Comment 4 Vitezslav Stejskal 2007-12-10 20:15:32 UTC
*** Issue 123715 has been marked as a duplicate of this issue. ***
Comment 5 leizzer 2007-12-18 20:47:10 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) Client VM, 1.6.0_02-b06
OS: Windows XP, 5.1, x86

User Comments: 
-------------------------------------------------------------------------------
>Log Session: Tuesday, December 18, 2007 5:49:01 PM CET
>System Info: 
  Product Version         = NetBeans IDE 6.0 (Build 200711261600)
  Operating System        = Windows XP version 5.1 running on x86
  Java; VM; Vendor        = 1.6.0_02; Java HotSpot(TM) Client VM 1.6.0_02-b06; Sun Microsystems Inc.
  Java Home               = C:\Archivos de programa\Java\jdk1.6.0_02\jre
  System Locale; Encoding = es_AR (nb); Cp1252
  Home Directory          = C:\Documents and Settings\Cristian
  Current Directory       = C:\Archivos de programa\NetBeans 6.0
  User Directory          = C:\Documents and Settings\Cristian\.netbeans\6.0
  Installation            = C:\Archivos de programa\NetBeans 6.0\nb6.0
                            C:\Archivos de programa\NetBeans 6.0\ide8
                            C:\Archivos de programa\NetBeans 6.0\java1
                            C:\Archivos de programa\NetBeans 6.0\xml1
         
Comment 6 leizzer 2007-12-18 20:47:14 UTC
Created attachment 54369 [details]
stacktrace
Comment 7 aanno 2007-12-27 14:24:14 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) 64-Bit Server VM, 1.6.0_03-b05
OS: Linux, 2.6.23-gentoo-r1, amd64

User Comments: 
Try to open java source code (in editor).
Comment 8 aanno 2007-12-27 14:24:22 UTC
Created attachment 54525 [details]
stacktrace
Comment 9 aannoaanno 2007-12-27 14:36:22 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) 64-Bit Server VM, 1.6.0_03-b05
OS: Linux, 2.6.23-gentoo-r1, amd64

User Comments: 
Comment 10 aannoaanno 2007-12-27 14:36:30 UTC
Created attachment 54526 [details]
stacktrace
Comment 11 aannoaanno 2007-12-27 14:37:27 UTC
Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) 64-Bit Server VM, 1.6.0_03-b05
OS: Linux, 2.6.23-gentoo-r1, amd64

User Comments: 
Try to open java source (in editor).
Comment 12 aannoaanno 2007-12-27 14:37:37 UTC
Created attachment 54527 [details]
stacktrace
Comment 13 Marian Mirilovic 2008-01-27 22:15:07 UTC
92 reports so far (more than 70 reported against NB 6.0 FCS, on all OSes with JDKs 1.5.0_07-1.6.0_03)
Comment 14 Jan Becicka 2008-02-01 14:22:15 UTC
Vito, please take a look at it. Thanks.
Comment 15 Exceptions Reporter 2008-02-01 20:36:41 UTC
THIS ISSUE HAS ALREADY 100 DUPLICATES
Comment 16 Vitezslav Stejskal 2008-02-07 10:22:47 UTC
Adding more careful checks on the attribute value types.

http://hg.netbeans.org/main?cmd=changeset;node=1d64ad537158
Comment 17 Jiri Prox 2008-03-04 08:37:06 UTC
v.
Comment 18 rbalada 2008-03-05 17:32:51 UTC
Fix ported to release601_fixes branch

Checking in EditorSettingsImpl.java;
/cvs/editor/settings/storage/src/org/netbeans/modules/editor/settings/storage/Attic/EditorSettingsImpl.java,v  <-- 
EditorSettingsImpl.java
new revision: 1.42.6.1; previous revision: 1.42
done
Comment 19 songxiaolei 2008-04-22 02:35:22 UTC
*** Issue 132833 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo