Bug 122512 - Eclipse Keyboard Shortcuts Missing
Eclipse Keyboard Shortcuts Missing
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Key bindings
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
release601_fixes_candidate1, release6...
: SIMPLEFIX
: 116836 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-21 14:36 UTC by dheffelfinger
Modified: 2008-02-22 07:38 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dheffelfinger 2007-11-21 14:36:31 UTC
Some Eclipse keyboard shortcuts are missing from the Eclipse Keybinding profile:

Location                Shortcut        Comment (Eclipse Lingo)
Edit -> File Members    Ctrl+O          Quick Outline
Edit-> Replace          Ctrl+F          Find/Replace
Edit -> Go To Type      Ctrl+T          Open Type
Other -> Toggle Comment Ctrl+/          Comment current line*
Source -> Fix Code      Ctrl+1          Quick Fix
Source -> Format        Ctrl+Shift+F    Format Source
Tools-> Go to File      Ctrl+Shift+R    Open Resource
Comment 1 dheffelfinger 2007-11-21 18:48:24 UTC
I found some additional keyboard shortcuts that don't work. I was pretty surprised to find these, since they are
standard keyboard shortcuts in most Windows applications (copy, cut, paste, undo, etc).

Here is the complete list (so far) of missing keyboard shortcuts from the Eclipse profile, I'll update if I find more.

Edit -> Copy 	        Ctrl+C	Copy
Edit -> Cut             Ctrl+X	Cut
Edit -> File Members 	Ctrl+O	Quick Outline
Edit -> Go To Type	Ctrl+T	Open Type
Edit-> Paste	        Ctrl+V	Paste
Edit -> Replace	        Ctrl+F	Find/Replace
Edit-> Undo	        Ctrl+Z	Undo
Other -> Toggle Comment	Ctrl+/	Toggle comment/uncomment current line
Source -> Fix Code	Ctrl+1	Quick Fix
Source -> Format	Ctrl+Shift+F	Format Source
Tools-> Go to File	Ctrl+Shift+R	Open Resource
Comment 2 dheffelfinger 2007-11-21 19:36:56 UTC
Here is an additional keymap that is missing:

Location:                Shortcut:      Eclipse Lingo: 
Refactor -> Find Usages	 Ctrl+Alt+H	Open Call Hiererchy
Comment 3 dheffelfinger 2007-11-21 19:51:40 UTC
A couple more:

Other -> Copy Selection else line down	Ctrl+Down Arrow	Copy Lines
Other -> Copy Selection else line up	Ctrl+Up Arrow	Duplicate Lines
Comment 4 dheffelfinger 2007-11-21 20:07:35 UTC
Location:               Shortcut:       Eclipse Lingo:
Other -> Insert Code	Alt+Shift+S	Source...
Comment 5 dheffelfinger 2007-11-21 20:29:59 UTC
One correction:

Location:               Shortcut:       Eclipse Lingo:
Edit -> Go To Type	Ctrl+Shift+T	Open Type

And a new missing shortcut:

Location:               Shortcut:       Eclipse Lingo:
Edit -> Hierarchy	Ctrl+T	Quick Type Hierarchy
Comment 6 dheffelfinger 2007-11-21 22:51:21 UTC
Two more corrections (my apologies):

Location:                               Shortcut:               Eclipse Lingo:
Other -> Copy Selection else line down	Ctrl+Alt+Down Arrow	Copy Lines
Other -> Copy Selection else line up	Ctrl+Alt+Up Arrow	Duplicate Lines

Note, I've also been updating the list on my blog, the list can be seen at:
http://www.jroller.com/heffel/entry/netbeans_6_0_eclipse_keyboard

It might be easier to read there than going through all the comments I've been leaving here.
Comment 7 dheffelfinger 2007-11-22 00:08:51 UTC
Found one more:

Location:                                       Shortcut:       Eclipse Lingo:
Other -> Insertion Point to Matching Brace	Ctrl+Shift+P	Go to Matching Bracket
Comment 8 klaasjanelzinga 2007-11-24 13:49:08 UTC
The thing I miss (really miss) is ctrl-T (ctrl-shift T). I use this at least 20 times a day in eclipse. Its a life saver
if youre programming to an interface and wish to navigate to an implementation of the interface.
Comment 9 dheffelfinger 2007-11-25 17:05:24 UTC
Found two additional missing keybindings from the Eclipse keymap:

Location:                               Shortcut:       Eclipse Lingo:
Other -> Move Selection else line down	Alt+Down Arrow	Move Lines Down
Other -> Move Selection else line up	Alt+Up Arrow	Move Lines Up
Comment 10 dheffelfinger 2007-11-26 02:57:57 UTC
One more correction:

Location:               Shortcut:  Eclipse Lingo:
Edit -> File Hierarchy	Ctrl+T	   Quick Type Hierarchy

I am still updating the list at http://www.jroller.com/heffel/entry/netbeans_6_0_eclipse_keyboard as I find corrections
or additions. The list of shortcuts is easier to read there.
Comment 11 Vitezslav Stejskal 2007-11-26 14:31:29 UTC
Huh, that sounds like our Eclipse profile is pretty much useless with so many missing shortcuts (including the very
basic ones). It should be easy to fix. Thanks for this nice report.
Comment 12 dheffelfinger 2007-11-27 18:20:06 UTC
One more:

Location:                               Shortcut:   Eclipse Lingo:
Other -> Show Documentation Popup	F2	    Show Tooltip Description
Comment 13 dheffelfinger 2007-11-28 00:35:47 UTC
vstejskal,

Since this should be an easy fix, is there any chance that the missing shortcuts could be included in NB 6 final?

David
Comment 14 Jiri Prox 2007-11-28 07:28:59 UTC
unfortunately not, 6.0 is almost released, but I suppose it will be possible to "import" keymap settings from dev build
to 6.0 once, this issue is fixed.
Comment 15 dheffelfinger 2007-11-30 20:31:41 UTC
Found one more:

Location:                       Shortcut:   Eclipse Lingo:
Edit -> Find in Projects	Ctrl+H	    Open Search Dialog

Blog post at http://www.jroller.com/heffel/entry/netbeans_6_0_eclipse_keyboard updated accordingly.
Comment 16 Vitezslav Stejskal 2007-12-03 11:01:52 UTC
Once fixed, we should be able to make it downloadable from AU, the module would be ide/defaults. I'm not exactly sure
how this would be called in the actual list under Tools -> Plugins.
Comment 17 Vitezslav Stejskal 2007-12-11 10:15:16 UTC
*** Issue 116836 has been marked as a duplicate of this issue. ***
Comment 18 _ tboudreau 2008-01-17 07:51:22 UTC
Raising priority to P2 - this is key functionality that does not work right.  Someone who tries it and the keybindings don't actually work is even less likely to try 
NetBeans in the future.
Comment 19 Jan Becicka 2008-02-01 14:28:01 UTC
Vito, please fix it. Thanks
Comment 20 Vitezslav Stejskal 2008-02-08 14:56:27 UTC
Should be fixed. David, could you please check the shortcuts in a dev build or 6.1M2 when it's ready? Thanks

http://hg.netbeans.org/main/rev/a6641e28225d
Comment 21 Jiri Prox 2008-02-11 12:23:08 UTC
I've gone through all shortcuts mentioned in this report and all works fine for me. 
It would be fine if someone with Eclipse experience would confirm it as well. 
Comment 22 pgebauer 2008-02-11 18:13:41 UTC
The fix has been ported into the release601_fixes branch.

Checking in mf-layer.xml;
/cvs/ide/defaults/src/org/netbeans/modules/defaults/Attic/mf-layer.xml,v  <--  mf-layer.xml
new revision: 1.56.8.1; previous revision: 1.56
done
Checking in Eclipse-keybindings.xml;
/cvs/ide/defaults/src/org/netbeans/modules/defaults/Attic/Eclipse-keybindings.xml,v  <--  Eclipse-keybindings.xml
new revision: 1.20.8.1; previous revision: 1.20
done
Comment 23 dheffelfinger 2008-02-21 15:03:57 UTC
I downloaded the latest NetBeans 6.0.1 patch by following the steps explained at
http://www.nabble.com/NetBeans-6.0.1-Patch1-Now-Available-td15596184.html

I went through all the Eclipse keyboard shortcuts. It looks like all but one of the 
shortcuts are now correct.

The one that is still not working is: 

Other -> Show Documentation Popup	F2	Show Tooltip Description

Comment 24 Jiri Prox 2008-02-22 07:38:42 UTC
yes F2 is still assigned to improper action, it works only between braces of method call, see issue 127116



By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo