Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 116836 - Some Eclipse key bindings are wrong or missing
Some Eclipse key bindings are wrong or missing
Status: RESOLVED DUPLICATE of bug 122512
Product: editor
Classification: Unclassified
Component: Key bindings
6.x
Other Windows XP
: P3 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
:
: 108409 118056 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-26 15:21 UTC by ksilz
Modified: 2007-12-11 10:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ksilz 2007-09-26 15:21:54 UTC
In the Java editor,[Ctrl]-[Z] doesn't trigger "Undo".  However, "Undo" works from the toolbar icon and from the menu.
Comment 1 Vitezslav Stejskal 2007-09-27 12:18:10 UTC
It's working fine in a dev build. What shortcuts profile and keyboard layout are you using? Some keyboard layouts have
the letters Y and Z swapped. Could that be the issue?
Comment 2 ksilz 2007-09-28 03:19:15 UTC
Ah, stupid me!  I'm using the Eclipse key binding, and I didn't even think that "[Ctrl]-[Z]" wouldn't be mapped to Undo.
 So the problem is that the Eclipse key binding had the non-existing key "UNDO" mapped to Undo.  I think this is a bug
because "[Ctrl]-[Z]" _is_ mapped to Undo in Eclipse, like everywhere else.
Comment 3 ksilz 2007-09-28 03:23:55 UTC
I checked it out at a glance, and the following, rather basic shortcuts are not mapped to the same keys as in Eclipse,
when using the Eclipse key bindings in Netbeans:

- Undo: non-existing "Undo" instead of [Ctrl]-[Z] 
- Copy: non-existing "Copy" instead of [Ctrl]-[C] 
- Cut: non-existing "Cut" instead of [Ctrl]-[X]
- Paste: non-existing "Paste" instead of [Ctrl]-[Z]
- Find: non-existing "Find" instead of [Ctrl]-[F]

There's more (all of the refactorings are wrong).  Guys, when you call it the "Eclipse key bindings", then it should
actually have the Eclipse keys as well. 
Comment 4 Jiri Prox 2007-10-10 08:49:36 UTC
*** Issue 118056 has been marked as a duplicate of this issue. ***
Comment 5 Vitezslav Stejskal 2007-10-24 11:03:04 UTC
*** Issue 108409 has been marked as a duplicate of this issue. ***
Comment 6 Vitezslav Stejskal 2007-10-24 11:28:26 UTC
From issue #108409:

CTRL-SHIFT-F : Reformat code
CTRL-7 or CTRL-/: Comment
some of the refactoring shortcuts
Comment 7 artibee 2007-12-10 19:20:45 UTC
Please also review this user's table of 21 missing keyboard shortcuts
(key bindings) from the NetBeans' Eclipse profile:

http://www.jroller.com/heffel/entry/netbeans_6_0_eclipse_keyboard
Comment 8 Vitezslav Stejskal 2007-12-11 10:15:20 UTC
Ok, let's track this problem in a single issue.

*** This issue has been marked as a duplicate of 122512 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo