Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 122043 - ArrayIndexOutOfBoundsException: 6
ArrayIndexOutOfBoundsException: 6
Status: RESOLVED WORKSFORME
Product: profiler
Classification: Unclassified
Component: Base
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: issues@profiler
issues@profiler
http://statistics.netbeans.org/except...
release601_fixes_candidate1, release6...
:
: 155671 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 17:29 UTC by Alexander Kouznetsov
Modified: 2009-05-13 15:47 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (878 bytes, text/plain)
2007-11-16 17:37 UTC, Alexander Kouznetsov
Details
stacktrace (882 bytes, text/plain)
2008-06-07 21:11 UTC, serb
Details
stacktrace (880 bytes, text/plain)
2008-06-23 21:03 UTC, cappicard
Details
stacktrace (883 bytes, text/plain)
2008-06-23 21:03 UTC, cappicard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2007-11-15 17:29:20 UTC
Build: NetBeans IDE 6.0 RC1 (Build 200711141200)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows XP, 5.1, x86
User comments: Was profiling AppletTest application in CPU mode, then switched to Memory Profiling and opened Live Results
STACKTRACE: (first 10 lines)
java.lang.ArrayIndexOutOfBoundsException: 6
        at
org.netbeans.lib.profiler.results.memory.MemoryDataFrameProcessor.doProcessDataFrame(MemoryDataFrameProcessor.java:124)
        at org.netbeans.lib.profiler.results.AbstractDataFrameProcessor.processDataFrame(AbstractDataFrameProcessor.java:85)
        at org.netbeans.lib.profiler.results.ProfilingResultsDispatcher$2.run(ProfilingResultsDispatcher.java:160)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
        at java.lang.Thread.run(Thread.java:619)

In fact it produces lot of exceptions. Please follow the URL. There are two other users reported the same problem.
Comment 1 Alexander Kouznetsov 2007-11-15 17:30:50 UTC
See also issue 121710
Comment 2 Alexander Kouznetsov 2007-11-16 17:37:32 UTC
Build: NetBeans IDE 6.0 RC1 (Build 200711160000)
VM: Java HotSpot(TM) Client VM, 1.6.0_03-b05
OS: Windows XP, 5.1, x86

User Comments: 
Modified profiling mode from CPU to memory liveness while profiling Tomcat Web Application.
Comment 3 Alexander Kouznetsov 2007-11-16 17:37:36 UTC
Created attachment 53141 [details]
stacktrace
Comment 4 Alexander Kouznetsov 2007-11-16 17:39:57 UTC
Highly reproducible issue in situation of modify profiling from CPU to Memory.
Comment 5 J Bachorik 2007-12-12 13:11:26 UTC
fixed problem with profiling results buffer not being cleared completely upon instrumentation change

Checking in ProfilerRuntime.java;
/cvs/profiler/libs/jfluid/src/org/netbeans/lib/profiler/server/ProfilerRuntime.java,v  <--  ProfilerRuntime.java
new revision: 1.2; previous revision: 1.1
done
Checking in ThreadInfo.java;
/cvs/profiler/libs/jfluid/src/org/netbeans/lib/profiler/server/ThreadInfo.java,v  <--  ThreadInfo.java
new revision: 1.2; previous revision: 1.1
done
Comment 6 Maksim Khramov 2008-02-01 13:29:00 UTC
Mentioned exception reproduced on Build 200801291616 endlessly.
Comment 7 Mikhail Kondratyev 2008-02-01 15:03:58 UTC
This has to be checked in 6.1 branch. PLease retest
Comment 8 Mikhail Kondratyev 2008-02-01 15:06:11 UTC
Based on prev comment changing status back to Fixed
Comment 9 Maksim Khramov 2008-02-01 16:13:09 UTC
Verified in Netbeans 6.1 Build 200801311204
Comment 10 pgebauer 2008-02-05 13:28:28 UTC
The fix has been ported into the release601_fixes branch.

Checking in ThreadInfo.java;
/cvs/profiler/libs/jfluid/src/org/netbeans/lib/profiler/server/Attic/ThreadInfo.java,v  <--  ThreadInfo.java
new revision: 1.1.12.1; previous revision: 1.1
done
Checking in ProfilerRuntime.java;
/cvs/profiler/libs/jfluid/src/org/netbeans/lib/profiler/server/Attic/ProfilerRuntime.java,v  <--  ProfilerRuntime.java
new revision: 1.1.12.1; previous revision: 1.1
done
Comment 11 Alexandr Scherbatiy 2008-02-15 11:48:40 UTC
verified.
Build: NetBeans IDE 6.0.1 (Build 200801291616) with NB601 Patch1
Comment 12 Michel Graciano 2008-05-08 18:22:35 UTC
Product Version: NetBeans IDE 6.1 (Build 200804211638)
Java: 1.6.0_06; Java HotSpot(TM) Client VM 10.0-b22
System: Linux version 2.6.24-17-generic running on i386; ISO-8859-1; pt_BR (nb)

I am facing this issue for 6.1...
Comment 13 J Bachorik 2008-05-08 18:28:42 UTC
You mean that when you follow the exact steps described in this issue you get the exact same exception?
Can you provide us with your IDE log file? Thanks
Comment 14 fcastano 2008-05-13 23:17:41 UTC
I am using netbeans 6.1 and I get java.lang.ArrayIndexOutOfBoundsException

...
Profiler Agent: 250 classes cached.Profiler Agent: 250 classes cached.
Profiler Agent: 250 classes cached.
Profiler Agent: 250 classes cached.
Profiler Agent: 250 classes cached.
Profiler Agent: 250 classes cached.
Profiler Agent: 250 classes cached.
Profiler Agent: 250 classes cached.
Profiler Agent: 250 classes cached.
Exception in thread "pool-1-thread-18" Exception in thread "pool-1-thread-20" May 13, 2008 9:05:26 PM
com.sun.enterprise.server.logging.SystemOutandErrHandler$LoggingByteArrayOutputStream flush
WARNING:
java.lang.ArrayIndexOutOfBoundsException: 11946
        at org.netbeans.lib.profiler.server.ProfilerRuntimeObjAlloc.traceObjAlloc(ProfilerRuntimeObjAlloc.java:108)
        at org.netbeans.lib.profiler.server.ProfilerRuntimeMemory.traceVMObjectAlloc(ProfilerRuntimeMemory.java:194)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
        at org.jruby.internal.runtime.methods.InvocationMethodFactory.getAnnotatedMethod(InvocationMethodFactory.java:497)
        at org.jruby.RubyModule.defineAnnotatedMethod(RubyModule.java:757)
        at org.jruby.RubyModule.defineAnnotatedMethod(RubyModule.java:725)
        at org.jruby.RubyModule.defineAnnotatedMethodsIndividually(RubyModule.java:621)
        at org.jruby.RubyModule.defineAnnotatedMethods(RubyModule.java:517)
        at org.jruby.javasupport.JavaClass.createJavaClassClass(JavaClass.java:943)
        at org.jruby.javasupport.Java.createJavaModule(Java.java:99)
        at org.jruby.javasupport.Java.load(Java.java:87)
        at org.jruby.ext.LateLoadingLibrary.load(LateLoadingLibrary.java:55)
        at org.jruby.runtime.load.LoadService.smartLoad(LoadService.java:334)
        at org.jruby.runtime.load.LoadService.require(LoadService.java:346)
        at org.jruby.javasupport.JavaEmbedUtils.initialize(JavaEmbedUtils.java:87)
        at org.jruby.rack.DefaultRackApplicationFactory.newRuntime(DefaultRackApplicationFactory.java:80)
        at org.jruby.rack.DefaultRackApplicationFactory.createApplication(DefaultRackApplicationFactory.java:144)
        at org.jruby.rack.DefaultRackApplicationFactory.newErrorApplication(DefaultRackApplicationFactory.java:105)
        at org.jruby.rack.DefaultRackApplicationFactory.init(DefaultRackApplicationFactory.java:39)
        at org.jruby.rack.PoolingRackApplicationFactory.init(PoolingRackApplicationFactory.java:53)
        at org.jruby.rack.RackServletContextListener.contextInitialized(RackServletContextListener.java:38)
        at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4529)
        at org.apache.catalina.core.StandardContext.start(StandardContext.java:5225)
        at com.sun.enterprise.web.WebModule.start(WebModule.java:326)
        at com.sun.enterprise.web.LifecycleStarter.doRun(LifecycleStarter.java:58)
        at com.sun.appserv.management.util.misc.RunnableBase.runSync(RunnableBase.java:314)
        at com.sun.appserv.management.util.misc.RunnableBase.run(RunnableBase.java:341)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
        at java.lang.Thread.run(Thread.java:619)


Fernando
Comment 15 J Bachorik 2008-05-14 12:37:00 UTC
fernando, i filed your problem under a diferent issue #135038 as it is completely different to the one described in this
entry.
hmichel, please, provide more info about how did you reproduce the problem, otherwise I will close this issue. 
Thanks
Comment 16 serb 2008-06-07 21:11:05 UTC
Created attachment 62526 [details]
stacktrace
Comment 17 cappicard 2008-06-23 21:03:02 UTC
Created attachment 63297 [details]
stacktrace
Comment 18 cappicard 2008-06-23 21:03:38 UTC
Created attachment 63298 [details]
stacktrace
Comment 19 mariadavydova 2008-08-27 16:37:54 UTC
doesn't reproduce in build Build 200808080301
Comment 20 Petr Cyhelsky 2009-03-09 17:28:49 UTC
*** Issue 155671 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo