Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 155671 - ArrayIndexOutOfBoundsException: 7577
ArrayIndexOutOfBoundsException: 7577
Status: RESOLVED DUPLICATE of bug 122043
Product: profiler
Classification: Unclassified
Component: Base
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@profiler
issues@profiler
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 15:11 UTC by varjasz
Modified: 2009-03-09 17:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (870 bytes, text/plain)
2008-12-17 15:11 UTC, varjasz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description varjasz 2008-12-17 15:11:47 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 1.5.0_15-b04, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_15-b04
OS: Windows XP, 5.1, x86

User Comments:
varjasz: CPU profile

GUEST: I am profiling  a remote application that runs with linux-amd64 profile pack.
The other app seems to continue  working, very slowly though.
After I have received contiuously different Exception alerts, with different 
numerical values, the profiled application shows the following errors:
Profiler Agent Error: Redefinition failed for classes:
<classname>.class
Profiler Agent Error: with message: Redefinition failed with error 64
Check JVMTI documentation for this error code.
Debug: writing class file: <classname>, into file: <classname>.class
Profiler Agent Error: Redefinition failed for classes:
<classname>
on different several classes.

miganb: I was profiling the Java2D demo with filter.
When trying to get a snapshot, the exception occurred.

GUEST: Profiling an application

varjasz: CPU profile



Stacktrace: 
java.lang.ArrayIndexOutOfBoundsException: 39
        at org.netbeans.lib.profiler.results.cpu.CPUDataFrameProcessor.doProcessDataFrame(CPUDataFrameProcessor.java:97)
        at org.netbeans.lib.profiler.results.AbstractDataFrameProcessor.processDataFrame(AbstractDataFrameProcessor.java:90)
        at org.netbeans.lib.profiler.results.ProfilingResultsDispatcher$1.run(ProfilingResultsDispatcher.java:128)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
        at java.util.concurrent.FutureTask.run(FutureTask.java:123)
Comment 1 varjasz 2008-12-17 15:11:54 UTC
Created attachment 75095 [details]
stacktrace
Comment 2 Petr Cyhelsky 2009-03-09 17:29:00 UTC
Duplicate of Issue #122043

*** This issue has been marked as a duplicate of 122043 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo