Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 121608 - Please provide method for modifying property project.license in freefrom ant
Please provide method for modifying property project.license in freefrom ant
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Ant Freeform
6.x
PC Windows XP
: P3 with 1 vote (vote)
: TBD
Assigned To: Milan Kubec
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 18:12 UTC by pfn
Modified: 2008-10-15 12:07 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pfn 2007-11-09 18:12:16 UTC
There appears to be no method of modifying properties such as project.license in a freeform ant project.  Please provide
a mechanism or documentation on how it is achievable.

I have tried creating a project.properties and a -init-project target in my ant file reading said property file, but it
has not been successful.  Being able to setup properties such as the project.license would be nice.
Comment 1 Petr Dvorak 2008-04-22 16:50:32 UTC
I think it is a duplicate of 92490, reopen the issue if I am wrong.

*** This issue has been marked as a duplicate of 92490 ***
Comment 2 pfn 2008-04-22 17:37:37 UTC
This is unrelated to 92490, the problem is when I am using an ant-based project instead of a NB project.  I am unable to
specify project license.
Comment 3 Jesse Glick 2008-04-23 13:48:23 UTC
I think there is <license> element or similar in project.xml, perhaps with a GUI field, at least in 6.1. Reassigning for
evaluation.
Comment 4 Milan Kubec 2008-10-15 12:07:30 UTC
Already implemented, see issue #115058.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo