Bug 118244 - Profiled app drops on Take Snapshot
Profiled app drops on Take Snapshot
Status: VERIFIED DUPLICATE of bug 113847
Product: profiler
Classification: Unclassified
Component: Base
6.x
PC Windows XP
: P2 (vote)
: TBD
Assigned To: issues@profiler
issues@profiler
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-09 15:13 UTC by Maksim Khramov
Modified: 2007-10-31 13:36 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Stacktrace log for this issue (2.41 KB, text/plain)
2007-10-09 15:16 UTC, Maksim Khramov
Details
JVM log file (9.59 KB, text/plain)
2007-10-09 15:38 UTC, Maksim Khramov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maksim Khramov 2007-10-09 15:13:26 UTC
Product Version: NetBeans IDE Dev (Build 200710090000)
Java: 1.6.0_02; Java HotSpot(TM) Client VM 1.6.0_02-b05
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)

Steps to reproduce:
Create new Anagram Game project.
Run it without profiler.
Invoke Attach Profiler and select Local Attach, Dynamic attach to External Application
Open SPT dialog.
Select memory profiling: Record both object creation and GC. Check Record stack trace option.
Attach profiler to Anagram Game application 
Invoke Take Snapshot from Control Panel.
Profiled application drops.

There are also exception in log. See attachment.
Comment 1 Maksim Khramov 2007-10-09 15:16:18 UTC
Created attachment 50504 [details]
Stacktrace log for this issue
Comment 2 Tomas Hurka 2007-10-09 15:28:23 UTC
1) It looks like JVM bug with dynamic attach - profiled JVM crashed. 
2) Find hs_err*.log and attach it.
Comment 3 Maksim Khramov 2007-10-09 15:39:04 UTC
Created attachment 50507 [details]
JVM log file
Comment 4 Tomas Hurka 2007-10-09 16:24:38 UTC
Indeed it looks like problem with dynamic attach. Try to disbale class-sharing (-Xshare:off) for profiled application.
Comment 5 Maksim Khramov 2007-10-10 10:55:49 UTC
It works when class sharing is disabled.
Comment 6 Alexander Kouznetsov 2007-10-16 14:37:56 UTC
Removed INCOMPLETE due to mkhramov answer.
Comment 7 J Bachorik 2007-10-16 15:09:29 UTC
in addition to not being INCOMPLETE it's also a duplicate

*** This issue has been marked as a duplicate of 113847 ***
Comment 8 Maksim Khramov 2007-10-31 13:36:23 UTC
Verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo