Bug 113847 - EXCEPTION_ACCESS_VIOLATION on Modify Profiling
EXCEPTION_ACCESS_VIOLATION on Modify Profiling
Status: VERIFIED WONTFIX
Product: profiler
Classification: Unclassified
Component: Base
6.x
PC Windows XP
: P2 (vote)
: TBD
Assigned To: issues@profiler
issues@profiler
: RELNOTE
: 118244 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 14:16 UTC by Alexander Kouznetsov
Modified: 2007-10-16 15:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Error report for JDK 1.6.0_01-b06 (8.16 KB, text/plain)
2007-08-27 14:18 UTC, Alexander Kouznetsov
Details
Error report for JDK 1.6.0_02-b06 (8.30 KB, text/plain)
2007-08-27 14:18 UTC, Alexander Kouznetsov
Details
JAlbum output (1.59 KB, text/plain)
2007-08-31 14:53 UTC, Alexander Kouznetsov
Details
Error report (10.28 KB, text/plain)
2007-08-31 14:54 UTC, Alexander Kouznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2007-08-27 14:16:59 UTC
Product Version: NetBeans IDE Dev (Build 200708270000) 
Java: 1.6.0_02; Java HotSpot(TM) Client VM 1.6.0_02-b06 
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)

Performed steps:
- Run AnagramGame app using java -jar .\Anagrams.jar command
- Performed Local Dynamic Attach: AngramGame project, Memory, Allocation, 10, record stack traces.
- Invoked Modify Profiling: changed 10 to 11. Pressed OK
- RESULT: Application was shut down with

#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x6d8491aa, pid=2260, tid=2444
#
# Java VM: Java HotSpot(TM) Client VM (1.6.0_02-b06 mixed mode, sharing)
# Problematic frame:
# V  [jvm.dll+0x891aa]

Reproduced also with JDK 1.6.0_01-b06:

#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x6d84896a, pid=272, tid=1776
#
# Java VM: Java HotSpot(TM) Client VM (1.6.0_01-b06 mixed mode, sharing)
# Problematic frame:
# V  [jvm.dll+0x8896a]
Comment 1 Alexander Kouznetsov 2007-08-27 14:18:00 UTC
Created attachment 47465 [details]
Error report for JDK 1.6.0_01-b06
Comment 2 Alexander Kouznetsov 2007-08-27 14:18:53 UTC
Created attachment 47466 [details]
Error report for JDK 1.6.0_02-b06
Comment 3 Tomas Hurka 2007-08-27 16:12:15 UTC
Workaround is to run profiled application with -Xshare:off. It looks like duplicate of issue #88776.
Comment 4 Tomas Hurka 2007-08-28 14:26:35 UTC
Entered as JDK bug 6598065 (http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6598065)
Comment 5 Alexander Kouznetsov 2007-08-31 14:52:07 UTC
Reproduced on New Album action in JAlbum application after Dynamic Attach to it. See attached logs.
Comment 6 Alexander Kouznetsov 2007-08-31 14:53:38 UTC
Created attachment 47889 [details]
JAlbum output
Comment 7 Alexander Kouznetsov 2007-08-31 14:54:28 UTC
Created attachment 47890 [details]
Error report
Comment 8 Alexander Kouznetsov 2007-08-31 14:55:02 UTC
Verified wontfix
Comment 9 J Bachorik 2007-10-16 15:09:17 UTC
*** Issue 118244 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo