Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 114456 - adding Web Applications plugin to Ruby install fails
adding Web Applications plugin to Ruby install fails
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
7.4
All Windows XP
: P1 (vote)
: -S1S-
Assigned To: Jiri Rechtacek
issues@platform
beta1fix
:
: 114284 (view as bug list)
Depends on: 113798
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-02 15:31 UTC by Patrick Keegan
Modified: 2014-08-01 14:13 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Keegan 2007-09-02 15:31:18 UTC
Using the 8/30 Ruby build, I tried to add Web Applications to my Ruby install through the Plugins window. 

However I get this error:

Warning - could not install some modules:
	JPA Refactoring - The module named org.netbeans.modules.j2ee.persistenceapi/1 was needed and not found.
	J2EE DD API - The module named org.netbeans.modules.j2ee.metadata.model.support/1 was needed and not found.
	Java Editor - The module named org.netbeans.modules.java.editor.lib/1 was needed and not found.
	Java Editor - The module named org.netbeans.modules.java.sourceui/1 was needed and not found.
	Java SE Projects - The module named org.netbeans.modules.j2ee.persistenceapi/1 was needed and not found.
	Java SE Projects - The module named org.netbeans.modules.java.sourceui/1 was needed and not found.
	J2EE Project Support Utilities - The module named org.netbeans.modules.java.editor.lib/1 was needed and not found.
	Web Freeform Project Support - The module named org.netbeans.modules.java.freeform/1 was needed and not found.
	JSP Editor - The module named org.netbeans.modules.java.editor.lib/1 was needed and not found.
	Web Projects - The module named org.netbeans.modules.j2ee.persistenceapi/1 was needed and not found.
	Web Projects - The module named org.netbeans.modules.websvc.serviceapi was needed and not found.
	RESTful Web Service Support API/SPI - The module named org.netbeans.modules.j2ee.metadata.model.support/1 was needed
and not found.
	Java - Navigation - The module named org.netbeans.modules.java.sourceui/1 was needed and not found.
	Web Services DD API - The module named org.netbeans.modules.j2ee.metadata.model.support/1 was needed and not found.
	Java Persistence API Support - The module named org.netbeans.modules.j2ee.persistenceapi/1 was needed and not found.
	Java Persistence - The module named org.netbeans.modules.j2ee.persistenceapi/1 was needed and not found.
	Java - The module named org.netbeans.modules.ant.kit was needed and not found.
	Java - The module named org.netbeans.modules.j2ee.metadata.model.support/1 was needed and not found.
	Java - The module named org.netbeans.modules.java.debug was needed and not found.
	Java - The module named org.netbeans.modules.java.editor.lib/1 was needed and not found.
	Java - The module named org.netbeans.modules.java.freeform/1 was needed and not found.
	Java - The module named org.netbeans.modules.java.helpset/1 was needed and not found.
	Java - The module named org.netbeans.modules.java.sourceui/1 was needed and not found.
	Java - The module named org.netbeans.modules.websvc.jaxrpc16/1 was needed and not found.
	Java - The module named org.netbeans.modules.websvc.serviceapi was needed and not found.
	Enterprise JavaBeans Core - The module named org.netbeans.modules.java.editor.lib/1 was needed and not found.
	Enterprise JavaBeans Core - The module named org.netbeans.modules.java.sourceui/1 was needed and not found.
	JPA Verification - The module named org.netbeans.modules.j2ee.persistenceapi/1 was needed and not found.
	29 further modules could not be installed due to the above problems.

Then I get the dialog that says Java, Ant, Web Applications, and Java Persistence are "successfully" installed. However,
the only project templates that are available are the Java SE samples, which of course can't be used since the project
infrastructure isn't there.

This is probably several bugs, but I would need help to divide them into separate issues. My concerns are:
*The adding of the plugins don't work (the plugins manager apparently does not fetch all of the modules it needs to make
the installation work)
*There is no clear workaround to make the install work after it has failed (such as suggestions to try to install other
modules first with the display name of those modules given)
Comment 1 Jiri Rechtacek 2007-09-03 10:56:47 UTC
Investigating...
Comment 2 Jiri Rechtacek 2007-09-03 16:51:40 UTC
Worksforme on my Ubuntu (Ruby build: netbeans-rubyide-hudson-3631.zip). Reproducible of Windows. Depends of issue 113798
- locked file while unpacking NBMs which causes early abort of NBM/Unpack.
Comment 3 Jiri Rechtacek 2007-09-04 15:58:16 UTC
Fixed in main trunk. Patrick, please verify on next nbrubyide build (http://deadlock.netbeans.org/hudson/job/ruby/) if
the fix works for you. If the fix works then I will backport the fix into beta1 branch. Thanks

Checking in src/org/netbeans/modules/autoupdate/services/InstallSupportImpl.java;
/shared/data/ccvs/repository/autoupdate/services/src/org/netbeans/modules/autoupdate/services/InstallSupportImpl.java,v
 <--  InstallSupportImpl.java
new revision: 1.22; previous revision: 1.21
done
Checking in libsrc/org/netbeans/updater/ModuleUpdater.java;
/shared/data/ccvs/repository/autoupdate/services/libsrc/org/netbeans/updater/ModuleUpdater.java,v  <--  ModuleUpdater.java
new revision: 1.9; previous revision: 1.8
done
Comment 4 Patrick Keegan 2007-09-04 18:50:45 UTC
using netbeans-hudson-trunk-3020-ruby.zip

the modules install and I am able to see them in action (web and java project types installed) on restart. A couple of
small things:

*I didn't notice anything saying that I needed to restart to get the modules installed
*When I restarted, I get a java.lang.reflect.InvocationTargetException (added to issue
http://www.netbeans.org/issues/show_bug.cgi?id=112217). I don't think this is related, but I'm not totally sure.

What should be my next steps? Should I try a different build and try to verify again?
Comment 5 Jaromir Uhrik 2007-09-05 10:25:39 UTC
It works perfectly now in the following hudson build in Win XP:
http://deadlock.netbeans.org/hudson/job/ruby/lastSuccessfulBuild/artifact/ruby/rubyide/dist/netbeans-rubyide-hudson-3672.zip
Patrick, could you please verify it on the same build? Jirka will then integrate the fix to beta branch.
Thanks.
Comment 7 Patrick Keegan 2007-09-05 11:09:20 UTC
See attachment (id=48135) for previous log file (sorry I accidentally attached to wrong issue)
http://www.netbeans.org/nonav/issues/showattachment.cgi/48135/messages.log.1

It works for me perfectly on build
http://deadlock.netbeans.org/hudson/job/ruby/lastSuccessfulBuild/artifact/ruby/rubyide/dist/netbeans-rubyide-hudson-3672.zip

in fact, I don't even need a restart, like I did on build netbeans-hudson-trunk-3020-ruby.zip

So, my question is, are we sure that we are comparing to the right bits?
Comment 8 Jiri Rechtacek 2007-09-05 13:18:57 UTC
The bug is still reproducible with build with enabled assertions.
Comment 9 Antonin Nebuzelsky 2007-09-05 13:44:23 UTC
I guess we want this fixed for Beta1, changing TM and priority.
Comment 10 Jiri Rechtacek 2007-09-05 14:10:45 UTC
Checking in ModuleUpdater.java;
/shared/data/ccvs/repository/autoupdate/services/libsrc/org/netbeans/updater/ModuleUpdater.java,v  <--  ModuleUpdater.java
new revision: 1.10; previous revision: 1.9
done
Comment 11 Jiri Rechtacek 2007-09-05 14:11:21 UTC
*** Issue 114284 has been marked as a duplicate of this issue. ***
Comment 12 Jesse Glick 2007-09-05 16:44:48 UTC
Was this the patch that added a call to File.getCanonicalFile()? Be careful with this method. On Unix it can cause
symlink targets to "leak" into the rest of the system in an undesirable way. Best to use FileUtil.normalizeFile when
available (I know it is not available in updater.jar).
Comment 13 Patrick Keegan 2007-09-05 19:07:44 UTC
the update worked for me in build http://deadlock.netbeans.org/hudson/job/trunk/3048/
Comment 14 Jiri Rechtacek 2007-09-06 11:56:27 UTC
Patrick, thanks for your verification.
Jesse, you are right that File.getCanonicalFile() could be risky on unix like systems. But transformation like this is
in ModuleUpdater for ages, I'll change it and generally fix it for beta2 - tracked as issue 114863.

Checking in src/org/netbeans/modules/autoupdate/services/InstallSupportImpl.java;
/shared/data/ccvs/repository/autoupdate/services/src/org/netbeans/modules/autoupdate/services/InstallSupportImpl.java,v
 <--  InstallSupportImpl.java
new revision: 1.21.2.1; previous revision: 1.21
done
Checking in libsrc/org/netbeans/updater/ModuleUpdater.java;
/shared/data/ccvs/repository/autoupdate/services/libsrc/org/netbeans/updater/ModuleUpdater.java,v  <--  ModuleUpdater.java
new revision: 1.8.8.1; previous revision: 1.8
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo