Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 114284 - Cannot load C/C++ plugin
Cannot load C/C++ plugin
Status: RESOLVED DUPLICATE of bug 114456
Product: cnd
Classification: Unclassified
Component: -- Other --
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Sergey Grinev
issues@cnd
:
Depends on: 113798
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-30 20:53 UTC by _ gordonp
Modified: 2007-09-05 14:11 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gordonp 2007-08-30 20:53:53 UTC
If I run the full installer then the C/C++ plugin gets loaded correctly. If I don't load the
plugin at installation time I cannot install it later using the plugin manager.

When I try and install C/C++ from the plugin manager I get the following error, "Plugin C/C++
cannot match its dependencies" and "module org.netbeans.modules.cnd.navigation > 1.0.Jesse
Glick and Pavel Buzek created a cnd/kit module. Perhaps this has something to do with the
dependency mismatch?
Comment 1 novakm 2007-09-03 09:15:21 UTC
Reassigning to cnd for evaluation.
Comment 2 Sergey Grinev 2007-09-03 16:10:31 UTC
Investigated on build 200708160000. Not reproduced on Solaris, on Windows reproduced, but with different log:

> Exception in thread "Thread-8" java.lang.AssertionError: Cannot delete C:\Program Files\NetBeans 6.0
> 200709030000\cnd1\update\download\org-netbeans-modules-cnd-folding.nbm
>	at org.netbeans.updater.ModuleUpdater.unpack(ModuleUpdater.java:365)
>	at org.netbeans.updater.ModuleUpdater.run(ModuleUpdater.java:116)
> Warning - could not install some modules:
>	C/C++ APT-based Folding - The module named org.netbeans.modules.cnd/1 was needed and not found.
>	C/C++ APT-based Folding - The module named org.netbeans.modules.cnd.antlr was needed and not found.
>	C/C++ APT-based Folding - The module named org.netbeans.modules.cnd.apt was needed and not found.

Probably autoupdater problem, see:
IZ114456 adding Web Applications plugin to Ruby install fails
IZ114091 Plugin installation gives "Warning - could not install some modules:"
IZ112885 "Could not install some modules" warning

Deferred till those bugs would be reviewed by guys working on autoupdater
Comment 3 Sergey Grinev 2007-09-04 11:08:51 UTC
Depends of issue 113798
- locked file while unpacking NBMs which causes early abort of NBM/Unpack.
Comment 4 Jiri Rechtacek 2007-09-05 14:11:22 UTC

*** This issue has been marked as a duplicate of 114456 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo