Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 111220 - Consistent installations causes warnings after changing environment (locale, platform, jvm arch)
Consistent installations causes warnings after changing environment (locale, ...
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: NBI
6.x
All All
: P3 (vote)
: 6.x
Assigned To: dlipin
issues@installer
:
: 117494 128962 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-27 11:35 UTC by Lukas Hasik
Modified: 2008-03-19 12:52 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nbi log (11.83 KB, text/plain)
2007-07-27 11:50 UTC, Lukas Hasik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2007-07-27 11:35:45 UTC
netbeans-6.0-nightly-200707250000-standard-windows.exe

this NPE apears when the installer runs in japanese locale.
Comment 1 Lukas Hasik 2007-07-27 11:50:39 UTC
Created attachment 45821 [details]
nbi log
Comment 2 dlipin 2007-07-30 11:54:04 UTC
Lukas,

Have you changed locale after the installation of one of the previous builds?

Dmitry
Comment 3 Lukas Hasik 2007-07-30 12:52:58 UTC
I had installed all the "previous" builds in EN locale. Then I switched to JA locale and wanted to install a newer
build. And it failed with the NPE.
I'm installing the netbeans-6.0-nightly-200707270000-standard-windows.exe in EN locale today. It works fine. 
Comment 4 dlipin 2007-07-30 13:22:02 UTC
Lukas, 

thanks for information.

The issue is that we store properties defined by property name + platform name + locale name. (e.g. 
installation.location.windows-x86.ru_RU).

We need to revise this strategy.

Dmitry
Comment 5 Lukas Hasik 2007-07-30 13:39:02 UTC
Dmitri, IMO, this is a corner case. Anyway, it is still a usecase. I think that it could be solved. You can just ignore
the "unreadable" properties file and behave like it is a first installation.

The worst thing is that it fails.
Comment 6 dlipin 2007-10-02 19:33:54 UTC
*** Issue 117494 has been marked as a duplicate of this issue. ***
Comment 7 dlipin 2007-10-16 11:21:20 UTC
NPE is no more thrown. But the other problem still exists - the warning message that says that it was not possible to 
get the installation location is shown.
Comment 8 Ken Frank 2007-10-19 21:25:20 UTC
I removed i18n summary and keywd - I saw the word locales in summary and thought it was related to i18n.

ken.frank@sun.com
Comment 9 dlipin 2008-03-03 08:52:38 UTC
*** Issue 128962 has been marked as a duplicate of this issue. ***
Comment 10 dlipin 2008-03-03 08:53:55 UTC
*** Issue 128962 has been marked as a duplicate of this issue. ***
Comment 11 dlipin 2008-03-19 12:52:25 UTC
Most of the issue is now fixed (jvm arch and locale changes are fixed, platform changes very rarely so it is not a 
common usecase).

http://hg.netbeans.org/main/rev/5cc34aae4897


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo