Bug 107881 - Deadlock from illegal call to FileOwnerQuery from FileSystemListener.fileFolderCreated
Deadlock from illegal call to FileOwnerQuery from FileSystemListener.fileFold...
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Milos Kleint
issues@platform
: THREAD
: 110669 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-22 19:48 UTC by Jesse Glick
Modified: 2008-06-26 11:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (21.07 KB, text/plain)
2007-06-22 19:49 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2007-06-22 19:48:32 UTC
IDE froze after trying to close main window. In "Java Source Worker Thread", a Filesystems API callback should not be
calling into a Projects API method.
Comment 1 Jesse Glick 2007-06-22 19:49:20 UTC
Created attachment 44290 [details]
Thread dump
Comment 2 Milos Kleint 2007-06-22 21:40:29 UTC
Well, I'm really missing a facility that would let me register URLs and notify me when they appear/disappers. 

I should probably get rid of the FileSystemListener class altogether and let each project deal with listening on treen
on it's own.
Comment 4 Milos Kleint 2007-06-27 09:31:27 UTC
fixed by copy pasting the ant/project solution. 
http://fisheye.codehaus.org/changelog/mevenide/?cs=4461
Comment 5 Milos Kleint 2007-07-24 08:20:48 UTC
*** Issue 110669 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo