Bug 106448 - I18N - diff viewer does not show multibyte properly
I18N - diff viewer does not show multibyte properly
Status: RESOLVED DUPLICATE of bug 85257
Product: utilities
Classification: Unclassified
Component: Diff
6.x
All All
: P2 (vote)
: TBD
Assigned To: diff-issues@utilities
diff-issues@utilities
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-13 03:52 UTC by Ken Frank
Modified: 2007-06-13 09:35 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
image (15.38 KB, image/gif)
2007-06-13 03:55 UTC, Ken Frank
Details
image (7.27 KB, image/gif)
2007-06-13 03:55 UTC, Ken Frank
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Frank 2007-06-13 03:52:20 UTC
see 106436 and 106438 since the problems there 
might be related to diff viewer instead;
also think this might impact subversion diff

see gif for details

Running in ja locale and using multibyte in j2se project  java class name and data, which is legal.

am not changing the default utf-8 project encoding (new feature for nb6)
(its utf-8 but it still shows chars ok of the default locale user is in when running
ide, which is the system locale; for me its solaris ja locale which is euc encoding.

showing the diff viewer for comparing 2 files,  the multibyte is not shown correctly; 
 - see attachments  for original file view which has the correct mbyte for reference, and the diff window comparing
these 2 files - which shows both correct and incorrect mbyte.  (only one of the 2 files being compared are shown since
the other one looks similar)

I am guessing that some changes/assumptions related to the feq implementation might have caused this problem
in that cvs module code might be assuming euc-jp encoding vs utf8.

the reason for this guess is that, if change the project encoding to euc-jp, create a new java file, and use mbyte,
the diff will show correctly.


clarification on the proj encoding property - user should not need to change it for default
case which is, they are in some locale when running ide and using the characters of that locale
in files - those chars should be shown correctly.
Comment 1 Ken Frank 2007-06-13 03:55:18 UTC
Created attachment 43585 [details]
image
Comment 2 Ken Frank 2007-06-13 03:55:42 UTC
Created attachment 43586 [details]
image
Comment 3 Tomas Stupka 2007-06-13 09:35:38 UTC

*** This issue has been marked as a duplicate of 85257 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo