Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 105422 - intermittently get no themes found error
intermittently get no themes found error
Status: RESOLVED DUPLICATE of bug 99063
Product: obsolete
Classification: Unclassified
Component: visualweb
6.x
PC Windows XP
: P3 (vote)
: TBD
Assigned To: Winston Prakash
issues@obsolete
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 17:47 UTC by Sherry Zhou
Modified: 2007-07-16 22:37 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sherry Zhou 2007-06-01 17:47:24 UTC
daily build 200705311200

It is intermittent. Sometime when double click or right click then select
auto-submit on Change at a dropdown, An dialog pops up with the exception below


com.sun.webui.theme.ThemeConfigurationException: No themes found.
	at com.sun.webui.theme.SPIThemeFactory.getThemeResources(SPIThemeFactory.java:490)
	at com.sun.webui.theme.SPIThemeFactory.getTheme(SPIThemeFactory.java:178)
	at com.sun.webui.jsf.util.ThemeUtilities.getTheme(ThemeUtilities.java:138)
	at
com.sun.webui.jsf.util.JavaScriptUtilities.getTheme(JavaScriptUtilities.java:311)
	at
com.sun.webui.jsf.util.JavaScriptUtilities.getModuleName(JavaScriptUtilities.java:262)
	at
com.sun.webui.jsf.component.customizers.AutoSubmitOnChangeAction.getSubmitScript(AutoSubmitOnChangeAction.java:144)
	at
com.sun.webui.jsf.component.customizers.AutoSubmitOnChangeAction.toggleAutoSubmit(AutoSubmitOnChangeAction.java:96)
	at
com.sun.webui.jsf.component.customizers.AutoSubmitOnChangeAction.invoke(AutoSubmitOnChangeAction.java:76)
	at
org.netbeans.modules.visualweb.insync.action.AbstractDisplayActionAction.invokeDisplayAction(AbstractDisplayActionAction.java:121)
	at
org.netbeans.modules.visualweb.insync.action.AbstractDisplayActionAction.access$200(AbstractDisplayActionAction.java:72)
	at
org.netbeans.modules.visualweb.insync.action.AbstractDisplayActionAction$SingleDisplayActionAction.actionPerformed(AbstractDisplayActionAction.java:250)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.JToggleButton$ToggleButtonModel.setPressed(JToggleButton.java:291)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1216)
	at
javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1257)
	at java.awt.Component.processMouseEvent(Component.java:6038)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3260)
	at java.awt.Component.processEvent(Component.java:5803)
	at java.awt.Container.processEvent(Container.java:2058)
	at java.awt.Component.dispatchEventImpl(Component.java:4410)
	at java.awt.Container.dispatchEventImpl(Container.java:2116)
	at java.awt.Component.dispatchEvent(Component.java:4240)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4322)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3986)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3916)
	at java.awt.Container.dispatchEventImpl(Container.java:2102)
	at java.awt.Window.dispatchEventImpl(Window.java:2429)
	at java.awt.Component.dispatchEvent(Component.java:4240)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
Comment 1 Peter Zavadsky 2007-06-01 21:53:35 UTC
Passing to components.
Comment 2 _ krystyna 2007-06-01 22:06:34 UTC
I am also seeing this exception and getting "Missing Body Element" intermittently
after creating EE5 projects today. Sandip says it is related to this exception.
Comment 3 _ sandipchitale 2007-06-01 22:17:30 UTC
No. I think the Missing Body Element error Krystina was seeing was due to 
exceptions about Application Not Initialised. It is true that the Theme code 
was calling into Mock container when the exception occured. Krys please file a 
separate bug for that.

Comment 4 Winston Prakash 2007-07-16 22:37:12 UTC

*** This issue has been marked as a duplicate of 99063 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo