Bug 99063 - Missing Body Element switching to new Woodstock theme
Missing Body Element switching to new Woodstock theme
Status: RESOLVED WONTFIX
Product: obsolete
Classification: Unclassified
Component: visualweb
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Winston Prakash
issues@obsolete
WOODSTOCK
: REGRESSION
: 105422 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-27 01:21 UTC by _ krystyna
Modified: 2007-07-16 22:37 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
sample woodstock theme (500.27 KB, application/octet-stream)
2007-03-27 01:23 UTC, _ krystyna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ krystyna 2007-03-27 01:21:26 UTC
Netbeans RC1 candidate build - dated 03261315
VWP dated 070321_1

WXP,
JDK1.6

1. Create an EE5 project. Add woodstock theme library via Library
(attaching sample jar)
2. IN project window, switch to this new theme. First we correctly 
   get prompt to "active theme has changed, stop and start ..."
3. Click OK
>Get big red component error "Missing Body Element" .. 
however body element is in Outline, jsp
Can't recover.

Here is exception to log. Deva says the second
informational exception is not the problem.
Assigning to components.

Can add a braveheart theme jar with no issues.



INFORMATIONAL *********** Exception occurred ************ at 4:51 PM on Mar 26,
2007
Annotation: Missing resource from class: java.util.PropertyResourceBundle
Annotation: Key which was not found: jsfx
java.util.MissingResourceException: Can't find resource for bundle java.util.Pro
pertyResourceBundle, key jsfx
        at java.util.ResourceBundle.getObject(ResourceBundle.java:386)
        at java.util.ResourceBundle.getString(ResourceBundle.java:346)
        at com.sun.webui.theme.JarTheme.getPathToJSFile(JarTheme.java:236)
        at com.sun.webui.jsf.util.JavaScriptUtilities.renderJavaScriptInclude(Ja
vaScriptUtilities.java:328)
        at com.sun.webui.jsf.util.JavaScriptUtilities.renderJsfxInclude(JavaScri
ptUtilities.java:167)
        at com.sun.webui.jsf.renderkit.html.HeadRenderer.renderAttributes(HeadRe
nderer.java:141)
        at com.sun.webui.jsf.renderkit.html.AbstractRenderer.encodeBegin(Abstrac
tRenderer.java:156)
        at javax.faces.component.UIComponentBase.encodeBegin(UIComponentBase.jav
a:810)
[catch] at com.sun.rave.insync.faces.FacesPageUnit.renderBean(FacesPageUnit.java
:1258)
        at com.sun.rave.insync.faces.FacesPageUnit.renderNode(FacesPageUnit.java
:1492)
        at com.sun.rave.insync.faces.FacesPageUnit.renderBean(FacesPageUnit.java
:1306)
        at com.sun.rave.insync.faces.FacesPageUnit.renderNode(FacesPageUnit.java
:1492)
        at com.sun.rave.insync.faces.FacesPageUnit.renderBean(FacesPageUnit.java
:1306)
        at com.sun.rave.insync.faces.FacesPageUnit.getFacesRenderTree(FacesPageU
nit.java:1076)
        at com.sun.rave.insync.faces.FacesPageUnit.renderHtml(FacesPageUnit.java
:1614)
        at com.sun.rave.insync.models.FacesModel.getHtmlDomFragment(FacesModel.j
ava:1554)
        at com.sun.rave.insync.models.FacesModel.findHtmlBody(FacesModel.java:15
78)
        at com.sun.rave.insync.models.FacesModel.getHtmlBody(FacesModel.java:156
6)
        at com.sun.rave.designer.jsf.JsfForm.getHtmlBody(JsfForm.java:434)
        at com.sun.rave.designer.WebForm.getHtmlBody(WebForm.java:863)
        at com.sun.rave.designer.WebForm.getHtmlBody(WebForm.java:849)
        at com.sun.rave.designer.DesignerPaneUI.resetPageBox(DesignerPaneUI.java
:582)
        at com.sun.rave.designer.WebForm.modelRefreshed(WebForm.java:1484)
        at com.sun.rave.designer.WebForm.access$200(WebForm.java:85)
        at com.sun.rave.designer.WebForm$HtmlDomProviderListener.modelRefreshed(
WebForm.java:1804)
        at com.sun.rave.designer.jsf.JsfForm.fireModelRefreshed(JsfForm.java:697
)
        at com.sun.rave.designer.jsf.JsfForm.refreshModel(JsfForm.java:555)
        at com.sun.rave.designer.jsf.RefreshServiceImpl.refreshDataObject(Refres
hServiceImpl.java:87)
        at com.sun.rave.designer.jsf.RefreshServiceImpl.refreshFolder(RefreshSer
viceImpl.java:103)
        at com.sun.rave.designer.jsf.RefreshServiceImpl.refreshProject(RefreshSe
rviceImpl.java:69)
        at com.sun.rave.designer.jsf.RefreshServiceImpl.refresh(RefreshServiceIm
pl.java:63)
        at com.sun.rave.project.jsfproject.ui.RaveThemesFolderNode$SetAsCurrentT
hemeAction.actionPerformed(RaveThemesFolderNode.java:339)
        at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:19
95)
        at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.jav
a:2318)
        at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel
.java:387)
        at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242
)
        at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
        at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1
170)
        at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMen
uItemUI.java:1211)
        at java.awt.Component.processMouseEvent(Component.java:6038)
        at javax.swing.JComponent.processMouseEvent(JComponent.java:3260)
        at java.awt.Component.processEvent(Component.java:5803)
        at java.awt.Container.processEvent(Container.java:2058)
        at java.awt.Component.dispatchEventImpl(Component.java:4410)
        at java.awt.Container.dispatchEventImpl(Container.java:2116)
        at java.awt.Component.dispatchEvent(Component.java:4240)
        at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4322
)
        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3986)

        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3916)
        at java.awt.Container.dispatchEventImpl(Container.java:2102)
        at java.awt.Window.dispatchEventImpl(Window.java:2429)
        at java.awt.Component.dispatchEvent(Component.java:4240)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThre
ad.java:273)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.
java:183)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThre
ad.java:173)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)

        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)

        at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
[org.netbeans.mdr.Logger] Invalid element found in attr. collection - removing.
[org.netbeans.mdr.Logger] Invalid element found in attr. collection - removing.
[org.netbeans.mdr.Logger] Invalid element found in attr. collection - removing.
[org.netbeans.mdr.Logger] Invalid element found in attr. collection - removing.
[org.netbeans.mdr.Logger] Invalid element found in attr. collection - removing.
[org.netbeans.mdr.Logger] Invalid element found in attr. collection - removing.
[org.netbeans.mdr.Logger] Invalid element found in attr. collection - removing.
[org.netbeans.mdr.Logger] Invalid element found in attr. collection - removing.
[org.netbeans.javacore] INFORMATIONAL *********** Exception occurred ***********
* at 4:52 PM on Mar 26, 2007
java.lang.Exception: Class not found in index: webapplication64.SessionBean1. Re
covering...
        at org.netbeans.modules.javacore.parser.MDRParser.resolveSuperTypes(MDRP
arser.java:1207)
        at org.netbeans.modules.javacore.parser.MDRParser.processAST(MDRParser.j
ava:375)
        at org.netbeans.modules.javacore.parser.MDRParser.processAST(MDRParser.j
ava:341)
        at org.netbeans.modules.javacore.parser.MDRParser.processAST(MDRParser.j
ava:319)
        at org.netbeans.modules.javacore.parser.MDRParser.enterMembers(MDRParser
.java:249)
        at org.netbeans.modules.javacore.jmiimpl.javamodel.ResourceImpl.directUp
date(ResourceImpl.java:739)
        at org.netbeans.modules.javacore.jmiimpl.javamodel.ResourceImpl.checkUpT
oDate(ResourceImpl.java:650)
        at org.netbeans.modules.javacore.jmiimpl.javamodel.ResourceImpl.updateFr
omFileObject(ResourceImpl.java:455)
        at org.netbeans.modules.javacore.ExclusiveMutex.parseIfNeeded(ExclusiveM
utex.java:285)
        at org.netbeans.modules.javacore.ExclusiveMutex.enter(ExclusiveMutex.jav
a:177)
        at org.netbeans.mdr.NBMDRepositoryImpl.beginTrans(NBMDRepositoryImpl.jav
a:234)
        at org.netbeans.modules.java.JavaEditor$2.run(JavaEditor.java:272)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:499)

        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java
:932)
Comment 1 _ krystyna 2007-03-27 01:23:11 UTC
Created attachment 39993 [details]
sample woodstock theme
Comment 2 _ krystyna 2007-03-27 18:23:10 UTC
This is a regression from 5.5
Comment 3 Dongmei Cao 2007-03-27 19:37:23 UTC
Actually, I don't know how valid this test is. There are lots of changes in the
theme from woodstock 4.0 to 4.0.2. The woodstock 4.0 theme can not work in
woodstock 4.0.2. If you want to test switching theme feature in VWP 5.5.1, you
need to create a new custom theme based on the woodstock 4.0.2 suntheme.
Comment 4 _ krystyna 2007-03-27 20:15:55 UTC
This is an incompatibility that users who developed a theme
for 5.5 cannot use it in 5.5.1. What are the changes needed to
fix the theme? These will have to be documented.
Comment 5 Jayashri Visvanathan 2007-04-23 18:16:45 UTC
Here is the comment for woodstock team on this issue:
"We have never been able to guarantee that an earlier theme is compatible with 
subsequent release. If we do, we cannot fix lot of bugs. The real answer is
tighten the theme calls to catch exceptions but this is a huge task and was
highlighted in a recent email I sent saying that it was impossible for the
components to run with a theme present. I had tried to see how far I would get
without the theme. After swallowing a dozen or so exceptions I gave up.Any
customizations to a theme must be brought forward with a new release
of the components.Alternatively we could prevent the theme from throwing any
exceptions and just log the failure, but it's not clear if that is appropriate
either. "


Given the above comment, this issue should be tracked under woodstock, not
visualweb. Can you file an issue against woodstock please ?

For now, I am downgrading this because this is turning out to be a docs issue.

Thanks
Comment 6 Chris Kutler 2007-05-30 22:54:34 UTC
While you are fixing this, maybe you can fix this bad English: "There seems to
be missing body element, which is required to designer to be able to work. You
need to fix the problem in the sources first."    For the first sentence, I
suggest There seems to be a missing body element, which is preventing the Visual
Designer from displaying the page."  As for the second sentence, I can't figure
out what it is trying to tell me. Maybe "You must edit either the Java source
file or the JSP source file, depending on where the error is, to correct the
error."   I can't say for sure if by sources they mean to check both JSP and
Java. Maybe only the JSP file causes this error. As there is no problem with
either my Java source or Java source and I haven't a clue why I am getting this
blasted message.
Comment 7 Winston Prakash 2007-07-12 02:36:53 UTC
I created a custom theme (via style builder) and used that to switching
theme. It works for me.
Comment 8 _ krystyna 2007-07-12 16:59:45 UTC
This is not resolved. This bug points to the migration problem from 5.5 -> 5.5.1: the 
themes are NOT compatible and a 5.5. custom theme needs to be rebuilt with the 5.5.1 structure.
From our Release Notes:


Customized themes from Visual Web Pack 5.5 Java EE5 projects will not work when added to Visual Web Pack 5.5.1.

    Description: Under this circumstance, the Visual Designer reports a "Missing Body Element" error.

    Workaround: The user must recreate customized themes within the IDE's 5.5.1 theme file structure.

Comment 9 Winston Prakash 2007-07-14 00:27:05 UTC
Woodstock bug created.

https://woodstock.dev.java.net/issues/show_bug.cgi?id=554
Comment 10 Winston Prakash 2007-07-16 22:37:05 UTC
*** Issue 105422 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo