Bug 105167 - Tasklist icon badging blocks EQ
Tasklist icon badging blocks EQ
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jan Lahoda
issues@java
: PERFORMANCE, THREAD
: 108743 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-30 16:55 UTC by Jesse Glick
Modified: 2007-07-12 16:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump excerpt (4.49 KB, text/plain)
2007-05-30 16:56 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2007-05-30 16:55:38 UTC
070524. I opened a Java source from an NBM project using --open CLI. The IDE
froze for a while before showing the document. Thread dumps revealed that
java.source.tasklist.ErrorAnnotator.annotateIcon is synchronously calling
ClassPath.getClassPath on the file, which is probably unwise as this may involve
nontrivial computation (esp. for NBM projects).
Comment 1 Jesse Glick 2007-05-30 16:56:48 UTC
Created attachment 42974 [details]
Thread dump excerpt
Comment 2 Jan Lahoda 2007-07-04 13:00:11 UTC
*** Issue 108743 has been marked as a duplicate of this issue. ***
Comment 3 Jan Lahoda 2007-07-12 16:29:14 UTC
The TaskCache is not accessed synchronously in AWT anymore:Checking in ErrorAnnotator.java;
/cvs/java/source/src/org/netbeans/modules/java/source/tasklist/ErrorAnnotator.java,v  <--  ErrorAnnotator.java
new revision: 1.4; previous revision: 1.3
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo