Bug 108743 - Do lazy icon annotations
Do lazy icon annotations
Status: RESOLVED DUPLICATE of bug 105167
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jan Lahoda
tasklist-issues@contrib
: PERFORMANCE, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-03 12:23 UTC by pzajac
Modified: 2007-07-04 13:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
AWT thread (6.73 KB, text/plain)
2007-07-03 12:24 UTC, pzajac
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pzajac 2007-07-03 12:23:26 UTC
[070703] 
I explorered nbcvs checkout in Favorites. It caused scanning of module list because task list was annotating icons in
AWT-EVENT-QUEUE...
...
t org.netbeans.api.java.classpath.ClassPath.getClassPath(ClassPath.java:516)
        at org.netbeans.modules.java.source.tasklist.TaskCache.isInError(TaskCache.java:338)
        at org.netbeans.modules.java.source.tasklist.ErrorAnnotator.annotateIcon(ErrorAnnotator.java:84)
        - locked <0x97136cc8> (a org.netbeans.modules.java.source.tasklist.ErrorAnnotator)
        at org.netbeans.modules.masterfs.MasterFileSystem$StatusImpl.annotateIcon(MasterFileSystem.java:423)
....
Comment 1 pzajac 2007-07-03 12:24:33 UTC
Created attachment 44660 [details]
AWT thread
Comment 2 Jan Lahoda 2007-07-04 13:00:11 UTC

*** This issue has been marked as a duplicate of 105167 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo