Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 103968 - Wrong position in contex menu
Wrong position in contex menu
Status: VERIFIED DUPLICATE of bug 138358
Product: webservices
Classification: Unclassified
Component: Code
6.x
All All
: P4 (vote)
: 6.x
Assigned To: bhate
issues@webservices
http://wiki.netbeans.org/wiki/view/Ed...
:
Depends on:
Blocks: 110703
  Show dependency treegraph
 
Reported: 2007-05-15 10:20 UTC by Jiri Prox
Modified: 2008-09-05 16:40 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (12.03 KB, image/png)
2007-05-15 10:21 UTC, Jiri Prox
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2007-05-15 10:20:46 UTC
NetBeans IDE Dev (Build 070515)
1.6.0_02-ea; Java HotSpot(TM) Client VM 1.6.0_02-ea-b02
Linux version 2.6.5-1.358 running on i386
en_US (nb); UTF-8

"Web Service Client Resources" has wrong position in the editor context menu. It
should not be located between Copy and Paste. See the screenshot.
Comment 1 Jiri Prox 2007-05-15 10:21:17 UTC
Created attachment 42404 [details]
screenshot
Comment 2 Milan Kuchtiak 2007-06-25 11:28:32 UTC
That's incorrect.
Comment 4 Jiri Prox 2007-08-02 08:40:47 UTC
It's better now, but I according the UIspec it should be left out completely. 
Jano is it right?
Comment 5 Lukas Jungmann 2007-08-02 09:49:23 UTC
probably bug/missing part in the UI spec - we can't remove "Web Service Client Resources" action group from the editor's
context menu without any replacement because there would be no simple/intuitive way for users to be able to call some
webservice from java/jsp file unless we want them to write all code by themselves.
Comment 6 jrojcek 2007-08-02 10:56:49 UTC
The idea is to move the Web Services actions into Insert submenu, together with other actions that "generate" code. Think about it as a sort of "New >" or "Add 
>" menu for inserting source code snippets.

Comment 7 Milan Kuchtiak 2007-08-02 16:13:48 UTC
Please, think about that more.
To put the actions to Insert submenu we'd need to have some API.
Anyway, that would be too hidden for users.
Comment 8 Milan Kuchtiak 2007-08-02 16:16:43 UTC
Please, find some reasonable solution, then reasign the issue to websvc. 
Comment 9 jrojcek 2007-08-03 09:02:46 UTC
I think the solution is reasonable. I'm not sure if implementable for 6.0.
Comment 10 Vitezslav Stejskal 2007-08-20 12:36:52 UTC
Not an editor problem.
Comment 11 bhate 2007-09-28 19:43:51 UTC
we will do in 6.0 if we have time. targeting post 6.0 for now.
Comment 12 Lukas Hasik 2008-03-20 10:25:33 UTC
please, re-evaluate and fix for 6.1 if possible
Comment 13 bhate 2008-03-20 23:10:46 UTC
I will make this P4.
We should investigate the insert code option for 6.1.next.
Comment 14 Lukas Jungmann 2008-04-14 17:16:15 UTC
moving opened issues where TM != dev to TM=TBD
Comment 15 Lukas Jungmann 2008-06-26 13:40:45 UTC

*** This issue has been marked as a duplicate of 138358 ***
Comment 16 Jiri Prox 2008-09-05 16:40:53 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo