Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 138358 - Move Web Services actions into Insert Code popup
Move Web Services actions into Insert Code popup
Status: RESOLVED FIXED
Product: webservices
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Milan Kuchtiak
issues@webservices
:
: 103968 (view as bug list)
Depends on:
Blocks: 123450
  Show dependency treegraph
 
Reported: 2008-06-26 13:27 UTC by jrojcek
Modified: 2009-02-19 23:29 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jrojcek 2008-06-26 13:27:01 UTC
The editor contextual menu contains various actions generating code snippets (Insert Code, EJB Methods, Enterprise Resources, Web Service Client Resources). 
For 6.5 we want to clean up the menu and make the code generation consistent. This effort includes moving all code generating items from the contextual 
menu into the Insert Code popup. 

For web services this means the following:

- Add "Web Service Operation Call..." into the "Insert Code" popup
- Remove the "Web Services Client Resources" submenu from editor's contextual menu

If there's more items generating code for web services, please let me know.
Comment 1 jrojcek 2008-06-26 13:28:33 UTC
This issue is part of the overall contextual menu cleanup for 6.5.
Comment 2 Lukas Jungmann 2008-06-26 13:35:48 UTC
Actually there are two actions from web services:

-call ws operation action:
   in all java related project types for all java and jsp files)
-add web service operation action:
   for all web service implementation java files (ie. those annotated by @WebService)
Comment 3 Lukas Jungmann 2008-06-26 13:40:43 UTC
*** Issue 103968 has been marked as a duplicate of this issue. ***
Comment 4 jrojcek 2008-06-26 14:07:43 UTC
I see. For the other action, use "Web Service Operation...".

The API for adding items into the Insert Code popup was discussed in issue 134239.
Comment 5 David Konecny 2008-07-22 22:42:24 UTC
Once you implement this issue update also EjbCore module templates - have a look at
http://hg.netbeans.org/main?cmd=changeset;node=ae56b18ff507 and you will see in the diff that I fixed it for EJB Methods
but next to them is also textual reference to Web Services. Thanks, -David
Comment 6 Lukas Jungmann 2008-12-22 14:18:50 UTC
this is done. Milan, can you add changesets to this issue, please? Thanks.
Comment 7 Quality Engineering 2008-12-23 17:12:16 UTC
Integrated into 'main-golden', will be available in build *200812231401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/8a367690b6c4
User: Lukas Jungmann <jungi@netbeans.org>
Log: IZ #138358: Move Web Services actions into Insert Code popup - tests update


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo