Bug 103088 - IDE hangs on < in empty HTML document
IDE hangs on < in empty HTML document
Status: VERIFIED DUPLICATE of bug 101620
Product: web
Classification: Unclassified
Component: HTML Editor
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Marek Fukala
Jindrich Sedek
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-02 09:03 UTC by Jiri Kovalsky
Modified: 2009-05-18 10:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Exceptions extracted from messages.log file. (4.73 KB, text/plain)
2007-05-02 09:07 UTC, Jiri Kovalsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kovalsky 2007-05-02 09:03:22 UTC
Development build #200704261800 of NetBeans 6.0
Windows XP, JDK 1.6.0 RC build #101

Description:
============
IDE throws exception when user tries to rewrite the default version of generated
HTML document from scratch and presses < character twice. This ends in the
frozen IDE occupying 100% of CPU cycles and completely unusable operating
system. The exceptions are attached. As a result user has to kill the IDE which
is very hard to do itself and takes 1 minute because of almost no resources for
processing mouse motion events.

Steps to reproduce:
===================
1. Launch development build of NetBeans 6.0 with empty userdir.
2. Invoke "File|New Project..." from main menu.
3. Push "Next >" and "Finish" buttons.
4. Invoke "File|New File..." from main menu.
5. Select "Other" category", "HTML File" file type and push "Next >" and
"Finish" buttons.
6. Press Ctrl+A to select whole text and press '<' character.
7. The first exception is thrown.
8. Press "Close" button and press '<' character again.
9. IDE throwns another exception and starts to consume 100% CPU.
Comment 1 Jiri Kovalsky 2007-05-02 09:07:57 UTC
Created attachment 42025 [details]
Exceptions extracted from messages.log file.
Comment 2 Marek Fukala 2007-05-02 09:20:24 UTC
Already fixed on April 26th. Thanks for the precise report anyway.

*** This issue has been marked as a duplicate of 101620 ***
Comment 3 Jiri Kovalsky 2007-05-02 09:35:20 UTC
Do you mean this will not be fixed in Milestone 9 build we are going to show off
at JavaOne? :-|

Anyway, what a shame I didn't download one more day old build not to waste my
time reporting this duplicate. :-)
Comment 4 Marek Fukala 2007-05-02 09:54:15 UTC
AFAIK the release60-m9 branch was created before Mila commited to trunk the
first fix which caused the problem. So M9 isn't broken, but still contains the
original problem, in trunk both the original problem and the regression are fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo