Bug 100130 - IOOBE during editing js file
IOOBE during editing js file
Status: VERIFIED FIXED
Product: javascript
Classification: Unclassified
Component: Editor
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Daniel Prusa
issues@javascript
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-05 16:51 UTC by Lukasz Grela
Modified: 2009-02-27 14:26 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.44 KB, application/octet-stream)
2007-04-05 16:52 UTC, Lukasz Grela
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukasz Grela 2007-04-05 16:51:42 UTC
1) paste below code into js file
ala="\xag";| "\x400"
2)the pipe represent position of cursor
3)press enter -> the exception should be thrown
Comment 1 Lukasz Grela 2007-04-05 16:52:02 UTC
Created attachment 40510 [details]
stacktrace
Comment 2 Daniel Prusa 2007-04-11 11:47:32 UTC
I cannot reproduce it. May be, it is dependent on context of the assignement
statement, can you attach the whole javascript file for reproduction, please?
Comment 3 Martin Schovanek 2007-04-11 16:45:08 UTC
Reproducible in build #070411 in case the sample code is on the last line (no \n
behind it).
Comment 4 Daniel Prusa 2007-04-12 08:38:02 UTC
Fixed.

/cvs/languages/engine/src/org/netbeans/modules/languages/features/IndentAction.java
new revision: 1.5; previous revision: 1.4
Comment 5 Radim Roska 2007-08-07 08:58:55 UTC
VERIFIED


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo