Bug 98853 - Code completion for javadoc tags
Code completion for javadoc tags
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Javadoc
6.x
All All
: P2 with 5 votes (vote)
: 6.x
Assigned To: Jan Pokorsky
issues@java
plan61
: PLAN
: 37691 87229 120212 124160 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-23 21:49 UTC by tprochazka
Modified: 2008-02-13 09:28 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tprochazka 2007-03-23 21:49:09 UTC
- autocomplete when I type @ and ctrl+space
- autocomplete class and method name after @see,@link, etc.
- autocomplete parameters name and classname after @param
...
Comment 1 Jan Pokorsky 2007-09-21 13:58:39 UTC
*** Issue 87229 has been marked as a duplicate of this issue. ***
Comment 2 Jan Pokorsky 2007-11-26 10:10:01 UTC
*** Issue 120212 has been marked as a duplicate of this issue. ***
Comment 3 Jan Pokorsky 2008-02-12 13:07:53 UTC
implemented as http://hg.netbeans.org/main/rev/7884a70f910e
Comment 4 Michel Graciano 2008-02-12 16:11:51 UTC
I think issue http://www.netbeans.org/issues/show_bug.cgi?id=37691 is already fixed, since the comments for this issue
include completion for @link.
Comment 5 Jan Pokorsky 2008-02-12 17:38:23 UTC
*** Issue 37691 has been marked as a duplicate of this issue. ***
Comment 6 Jesse Glick 2008-02-12 23:48:56 UTC
BTW probably filed separately, but in case not: if you complete e.g.

{@link BigInteger}

then the IDE will helpfully insert also

import java.math.BigInteger;

but this import will be marked as unused, and if you remove it, there is no warning that the Javadoc link is now invalid.
Comment 7 Jan Pokorsky 2008-02-13 09:25:13 UTC
jglick: see issue #122484
Comment 8 Jan Pokorsky 2008-02-13 09:28:43 UTC
*** Issue 124160 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo