Bug 98673 - Dynamic Attach doesn't work with Firefox
Dynamic Attach doesn't work with Firefox
Status: VERIFIED WORKSFORME
Product: profiler
Classification: Unclassified
Component: Base
6.x
All All
: P2 (vote)
: 6.x
Assigned To: issues@profiler
issues@profiler
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-22 15:36 UTC by Alexander Kouznetsov
Modified: 2007-08-20 12:56 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
JDK crash log (11.91 KB, text/plain)
2007-03-22 15:37 UTC, Alexander Kouznetsov
Details
JDK crash log (10.85 KB, text/plain)
2007-03-22 15:38 UTC, Alexander Kouznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2007-03-22 15:36:14 UTC
Profiler 070322
NetBeans IDE Dev (Build 200703211900)
1.6.0; Java HotSpot(TM) Client VM 1.6.0-b105
Windows XP version 5.1 running on x86
ru_RU (nb); Cp1251

Mozilla Firefox 2.0.0.3

Steps to reproduce:
- Open Applet in Firefox
(http://www.netbeans.org/nonav/issues/showattachment.cgi/39348/applet.zip)
- Try to perform dynamic attach to it (Analyze Performance, Entire Application,
Profile All Classes)
- RESULT: Browser is shut down with
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0xac000bb6, pid=1288, tid=4052
or
#  Internal Error (53484152454432554E54494D450E435050020F), pid=2892, tid=3696
Comment 1 Alexander Kouznetsov 2007-03-22 15:37:45 UTC
Created attachment 39819 [details]
JDK crash log
Comment 2 Alexander Kouznetsov 2007-03-22 15:38:05 UTC
Created attachment 39820 [details]
JDK crash log
Comment 3 Tomas Hurka 2007-03-22 17:26:05 UTC

*** This issue has been marked as a duplicate of 88776 ***
Comment 4 Alexander Kouznetsov 2007-03-26 21:28:19 UTC
This is not a 100% duplicate since issue 88776 covers only 
#  Internal Error (53484152454432554E54494D450E435050020F), pid=2892, tid=3696

It has nothing about
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0xac000bb6, pid=1288, tid=4052

The latter one was also reproduced with dynamic attach to JBoss 4.0.5 GA.
Comment 5 Tomas Hurka 2007-03-27 17:49:20 UTC
If you believe that those JDK crash logs are caused by different bugs, you
should file separate issue for each of them. Closing as duplicate based on the
second JVM crash log.

*** This issue has been marked as a duplicate of 88776 ***
Comment 6 Alexander Kouznetsov 2007-03-28 08:35:27 UTC
There is no need to file one more issue. The issue is already filed and its id
is 98673. Please stop closing it as a duplicate.
Comment 7 Tomas Hurka 2007-07-11 13:29:18 UTC
I cannot reproduce it with 
Profiler 070711
Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
JDK 1.6.0_02
Mozilla Firefox 2.0.0.4

Closing as works for me. Please reopen if you can still reproduce it.
Comment 8 Alexander Kouznetsov 2007-08-20 12:56:23 UTC
Verified with
Product Version: NetBeans IDE Dev (Build 200708200000) 
Java: 1.6.0; Java HotSpot(TM) Client VM 1.6.0-b105 
System: Windows XP version 5.1 running on x86; Cp1251; ru_RU (nb)
Firefox 2.0.0.6


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo