Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 98238 - RE: Navigate to Source does not work for method which uses generic in parameter type
RE: Navigate to Source does not work for method which uses generic in paramet...
Status: VERIFIED FIXED
Product: uml
Classification: Unclassified
Component: Synchronization
5.x
All All
: P2 (vote)
: TBD
Assigned To: issues@uml
issues@uml
JAVA5,HOL
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-19 17:48 UTC by Andrew Korostelev
Modified: 2007-05-22 11:30 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Korostelev 2007-03-19 17:48:59 UTC
If operation uses generic to parameterize parameter's type, 
Navigate to Source does not work.

- create java project with operation like:
void add(Vector<String> name){}
- RE java project into uml project
- invoke 'Navigate to source' for generated 
void add (String name[0..*])
operation.
It doesn't work.
Comment 1 Andrew Korostelev 2007-03-19 17:50:20 UTC
there is a related case with generic describing, when Navigate To source works -
issue 78393.
Comment 2 Andrew Korostelev 2007-03-19 17:52:23 UTC

*** This issue has been marked as a duplicate of 94936 ***
Comment 3 Peter Lam 2007-05-19 01:13:25 UTC
This issue works now but issue 94936 is not so I'm separating this issue from
issue 94936.
Comment 4 Peter Lam 2007-05-19 01:14:20 UTC
separating issue from issue 94936.
Comment 5 Peter Lam 2007-05-19 01:15:39 UTC
already fixed.
Comment 6 Peter Lam 2007-05-19 01:16:33 UTC
verified in griffin patch.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo