Bug 9820 - [Win2K NB Dev 132] removed GridBag constraints by settign some properties
[Win2K NB Dev 132] removed GridBag constraints by settign some properties
Status: CLOSED FIXED
Product: guibuilder
Classification: Unclassified
Component: Code
3.x
PC Windows ME/2000
: P1 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
:
: 9916 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-24 00:40 UTC by javaiware
Modified: 2003-06-30 18:27 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Files before the GridBagConstraints are removed by NB Dev 132 (7.81 KB, application/octet-stream)
2001-07-21 01:02 UTC, javaiware
Details
Files after the GridBagConstraints are removed by NB Dev 132 (7.70 KB, application/octet-stream)
2001-07-21 01:02 UTC, javaiware
Details

Note You need to log in before you can comment on or make changes to this bug.
Description javaiware 2001-02-24 00:40:11 UTC
When opening a form that uses GridBagLayout (or any of the containers on the 
form uses it), the GridBagConstraints are removed from the protected code 
blocks. Please see attached files. The files in Before.ZIP are the files that 
still have the full GridBagConstraints in them. The files in After.ZIP are the 
files after opening the form.
When I open the form, NB tells me that the file needs to be changed (using the 
asterisk in the window title) and when I save the file the GridBagConstraints 
are gone.

Iwan
Comment 1 javaiware 2001-02-24 00:41:44 UTC
Created attachment 670 [details]
Files before the GridBagConstraints are removed by NB Dev 132
Comment 2 javaiware 2001-02-24 00:42:26 UTC
Created attachment 671 [details]
Files after the GridBagConstraints are removed by NB Dev 132
Comment 3 javaiware 2001-02-24 00:46:04 UTC
In addition to my initial bug report, the GridBagConstraints do show up correct 
in the properties editor, which means that the form-file is okay. Also, at 
design-time the form looks okay, but at runtime the problem with the missing 
constraints surface.

Iwan
Comment 4 javaiware 2001-02-24 01:11:50 UTC
Just another addition to my comments: When you open just the .java file (right-
click on the node in explorer and select 'Edit', the file is not being changed. 
So the problem resides in the parsing of the .form and (re-)generation of the 
code from the form.

Iwan
Comment 5 Tomas Pavek 2001-02-26 09:38:48 UTC
Fixed.
Comment 6 Marian Mirilovic 2001-02-26 10:43:19 UTC
verified in [nb-dev](133)
Comment 7 Marian Mirilovic 2001-02-27 17:03:16 UTC
Only change summary
Comment 8 Marian Mirilovic 2001-03-02 08:09:22 UTC
*** Issue 9916 has been marked as a duplicate of this issue. ***
Comment 9 Quality Engineering 2003-06-30 18:27:12 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo