Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 95741 - NB performance regression as a result of the endorsed mechanism
NB performance regression as a result of the endorsed mechanism
Status: VERIFIED FIXED
Product: webservices
Classification: Unclassified
Component: JAX-WS
6.x
All All
: P2 (vote)
: 5.x
Assigned To: Milan Kuchtiak
issues@webservices
551_HR_FIX
: PERFORMANCE
: 94617 (view as bug list)
Depends on: 96711
Blocks: 91346 106018
  Show dependency treegraph
 
Reported: 2007-02-15 21:47 UTC by Roderico Cruz
Modified: 2007-06-07 19:34 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roderico Cruz 2007-02-15 21:47:58 UTC
This is to track the 5% performance regression that is a result of adopting the
endorsed mechanism to work around the class loader problem with JDK 1.6. Quoting
Radim:
Note that after integration to trunk we see approx. 5% startup regression due
more JARs on bootclasspath and mainly disabled class data sharing. Manual
measurements comparing builds from Jan 29 and Jan 31 on my P3/800MHz/512MB/Linux
Ubuntu0610/JDK1.6.0_01-b03 desktop show similar numbers and 6-7% regresion for a
cold start.
Note that the endorsed mechanism is temporary for beta.
Comment 1 Milan Kuchtiak 2007-02-23 11:02:11 UTC
Implement changes in NbInstaller and build-impl :

NbInstaller changes :
mask following packages from jdk1.6

        "javax/xml/bind/"
        "javax/xml/ws/"
        "javax/xml/stream/"
        "javax/jws/'
        "javax/xml/soap/"

changes in build scripts :
 - fork wsimport/wsgen tasks
 - specify jaxws.endorsed.dir (private) property
 - specify endorsed library in wsgen/wsimport :
   <jvmarg value="-Djava.endorsed.dirs=${{jaxws.endorsed.dir}}"/>

/cvs/core/startup/src/org/netbeans/core/startup/NbInstaller.java,v  <-- 
NbInstaller.java
new revision: 1.39; previous revision: 1.38

websvc/jaxwsmodel/src/org/netbeans/modules/websvc/api/jaxws/project/WSUtils.java;
/cvs/websvc/jaxwsmodel/src/org/netbeans/modules/websvc/api/jaxws/project/WSUtils.java,v
 <--  WSUtils.java
new revision: 1.3; previous revision: 1.2

Checking in web/project/src/org/netbeans/modules/web/project/WebProject.java;
/cvs/web/project/src/org/netbeans/modules/web/project/WebProject.java,v  <-- 
WebProject.java
new revision: 1.101; previous revision: 1.100

web/project/src/org/netbeans/modules/web/project/resources/build-impl.xsl;
/cvs/web/project/src/org/netbeans/modules/web/project/resources/build-impl.xsl,v
 <--  build-impl.xsl
new revision: 1.116; previous revision: 1.115

j2ee/clientproject/src/org/netbeans/modules/j2ee/clientproject/AppClientProject.java;
/cvs/j2ee/clientproject/src/org/netbeans/modules/j2ee/clientproject/AppClientProject.java,v
 <--  AppClientProject.java
new revision: 1.3; previous revision: 1.2

j2ee/clientproject/src/org/netbeans/modules/j2ee/clientproject/resources/build-impl.xsl;
/cvs/j2ee/clientproject/src/org/netbeans/modules/j2ee/clientproject/resources/build-impl.xsl,v
 <--  build-impl.xsl
new revision: 1.7; previous revision: 1.6

j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/EjbJarProject.java;
/cvs/j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/EjbJarProject.java,v
 <--  EjbJarProject.java
new revision: 1.62; previous revision: 1.61
done
Checking in
j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/resources/build-impl.xsl;
/cvs/j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/resources/build-impl.xsl,v
 <--  build-impl.xsl
new revision: 1.64; previous revision: 1.63

java/j2seproject/src/org/netbeans/modules/java/j2seproject/J2SEProject.java;
/cvs/java/j2seproject/src/org/netbeans/modules/java/j2seproject/J2SEProject.java,v
 <--  J2SEProject.java
new revision: 1.74; previous revision: 1.73

java/j2seproject/src/org/netbeans/modules/java/j2seproject/resources/build-impl.xsl;
/cvs/java/j2seproject/src/org/netbeans/modules/java/j2seproject/resources/build-impl.xsl,v
 <--  build-impl.xsl
new revision: 1.81; previous revision: 1.80
Comment 2 _ rkubacki 2007-02-23 11:08:18 UTC
You made some typos in licence header of NbInstaller, please fix it.

It would be good if Marian can check if this really revret back performance
results back.
Comment 3 _ rkubacki 2007-02-25 19:41:08 UTC
I'm reverting change in Windows launcher.

cvs -z6 -w -q commit -m "#95741: reverting back support for passing
-Djava.endorsed.dirs. \nWe will load e..." -- nb.exe netbeans.cpp netbeans.exe
(in directory E:\nb\nb_all\ide\launcher\windows\)
Checking in nb.exe;
/shared/data/ccvs/repository/ide/launcher/windows/nb.exe,v  <--  nb.exe
new revision: 1.27; previous revision: 1.26
done
Checking in netbeans.cpp;
/shared/data/ccvs/repository/ide/launcher/windows/netbeans.cpp,v  <--  netbeans.cpp
new revision: 1.30; previous revision: 1.29
done
Checking in netbeans.exe;
/shared/data/ccvs/repository/ide/launcher/windows/netbeans.exe,v  <--  netbeans.exe
new revision: 1.27; previous revision: 1.26
done
Comment 4 _ rkubacki 2007-02-25 19:53:50 UTC
Checking in ide/launcher/unix/netbeans;
/shared/data/ccvs/repository/ide/launcher/unix/netbeans,v  <--  netbeans
new revision: 1.44; previous revision: 1.43
done
Comment 5 Roderico Cruz 2007-02-26 17:36:43 UTC
The changes look fine. Kindly port it to the 5.5.1 release.
Comment 6 _ rkubacki 2007-02-27 18:29:57 UTC
Milan, as you are commiting your changes to core/startup please add test for
this functionality - check that a module declaring proper dependency gets
expected verision of classes
Comment 7 Lukas Jungmann 2007-02-28 11:33:52 UTC
v. in trunk, feel free to check in to release551
Comment 8 Milan Kuchtiak 2007-03-02 08:30:43 UTC
Rollbacked changes in NB launcher :
Checking in windows/nb.exe;
/cvs/ide/launcher/windows/nb.exe,v  <--  nb.exe
new revision: 1.15.2.3.2.5.28.2; previous revision: 1.15.2.3.2.5.28.1
done
Checking in windows/netbeans.cpp;
/cvs/ide/launcher/windows/netbeans.cpp,v  <--  netbeans.cpp
new revision: 1.17.2.2.2.6.22.2; previous revision: 1.17.2.2.2.6.22.1
done
Checking in windows/netbeans.exe;
/cvs/ide/launcher/windows/netbeans.exe,v  <--  netbeans.exe
new revision: 1.15.2.3.2.5.28.2; previous revision: 1.15.2.3.2.5.28.1
done
Checking in unix/netbeans;
/cvs/ide/launcher/unix/netbeans,v  <--  netbeans
new revision: 1.23.2.3.2.6.22.2; previous revision: 1.23.2.3.2.6.22.1
Comment 9 Milan Kuchtiak 2007-03-02 11:28:30 UTC
Merged changes from trunk to 5.5.1 :

/cvs/core/startup/src/org/netbeans/core/startup/NbInstaller.java,v  <-- 
NbInstaller.java
new revision: 1.13.2.3.2.1.22.1; previous revision: 1.13.2.3.2.1

/cvs/websvc/jaxwsmodel/src/org/netbeans/modules/websvc/api/jaxws/project/WSUtils.java,v
 <--  WSUtils.java
new revision: 1.1.2.17.10.1; previous revision: 1.1.2.17

/cvs/j2ee/clientproject/src/org/netbeans/modules/j2ee/clientproject/AppClientProject.java,v
 <--  AppClientProject.java
new revision: 1.1.4.25.8.1; previous revision: 1.1.4.25

/cvs/java/j2seproject/src/org/netbeans/modules/java/j2seproject/resources/build-impl.xsl,v
 <--  build-impl.xsl
new revision: 1.58.2.5.2.12.6.1; previous revision: 1.58.2.5.2.12

/cvs/java/j2seproject/src/org/netbeans/modules/java/j2seproject/J2SEProject.java,v
 <--  J2SEProject.java
new revision: 1.56.2.2.2.12.18.1; previous revision: 1.56.2.2.2.12

/cvs/web/project/src/org/netbeans/modules/web/project/WebProject.java,v  <-- 
WebProject.java
new revision: 1.85.2.3.2.41.6.1; previous revision: 1.85.2.3.2.41
 /cvs/j2ee/clientproject/src/org/netbeans/modules/j2ee/clientproject/resources/build-impl.xsl,v
 <--  build-impl.xsl
new revision: 1.1.4.25.8.3; previous revision: 1.1.4.25.8.2

/cvs/web/project/src/org/netbeans/modules/web/project/resources/build-impl.xsl,v
 <--  build-impl.xsl
new revision: 1.100.12.6.2.53.6.1; previous revision: 1.100.12.6.2.53

/cvs/j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/resources/build-impl.xsl,v
 <--  build-impl.xsl
new revision: 1.49.16.4.2.30.8.1; previous revision: 1.49.16.4.2.30

/cvs/j2ee/ejbjarproject/src/org/netbeans/modules/j2ee/ejbjarproject/EjbJarProject.java,v
 <--  EjbJarProject.java
new revision: 1.50.2.6.2.34.8.1; previous revision: 1.50.2.6.2.34
Comment 10 Marian Mirilovic 2007-03-05 20:04:07 UTC
We are back in green numbers !
NB 5.5.1 (200703050600)
Comment 11 Petr Nejedly 2007-04-20 22:34:48 UTC
*** Issue 94617 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo