Bug 93878 - I18N - RFE - provide ways of using netbeans i18n wizards and other functionality in creator
I18N - RFE - provide ways of using netbeans i18n wizards and other functional...
Status: RESOLVED DUPLICATE of bug 93877
Product: obsolete
Classification: Unclassified
Component: visualweb
5.x
Sun Solaris
: P2 (vote)
: 6.x
Assigned To: Winston Prakash
issues@obsolete
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-01 22:00 UTC by bugbridge
Modified: 2007-12-07 16:41 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2007-02-01 22:00:47 UTC
Description:
from customer feedback and  based on discussions with Alexander
(or from other analysis and discussions of issues and features where we thought
an rfe for i18n could be helpful)

if this is duplicate of existing rfe related to i18n, please close
as duplicate; we have looked at existing rfes with words i18n in synopsis and
tried not to file any duplicates. 

customer feedback - 
to be able to configure (on a
project-basis) the page-bean superclass (default = AbstractPageBean)

(this is not related to i18n but came up as part of i18n functionality
discussions - Craig knows more about this.)

Description (Entry 2):
additional information from customer:

it should be possible to create my own
Subclass of AbstractPageBean and use it as the page-bean-class in
Creator, to add common functionality / code in one single place.
Currently, trying to use my own subclass of AbstractPageBean fails,
because Creator complains (something about page beans have to be
extended *directly* from a handful of allowed classes).
Comment 1 Winston Prakash 2007-07-16 23:00:20 UTC

*** This issue has been marked as a duplicate of 93877 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo