Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 92866 - EJB 2.1 business interfaces are not generated
EJB 2.1 business interfaces are not generated
Status: RESOLVED WORKSFORME
Product: javaee
Classification: Unclassified
Component: EJB
6.x
All All
: P3 (vote)
: 6.x
Assigned To: _ jyothivasa
issues@javaee
: REGRESSION
Depends on:
Blocks: 92999
  Show dependency treegraph
 
Reported: 2007-01-19 16:56 UTC by Lukas Jungmann
Modified: 2008-11-07 22:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Jungmann 2007-01-19 16:56:43 UTC
Steps similar to ones in issue 92396, but use J2EE 1.4 w/ source level 1.4

=> + there's missing business interface
Comment 1 Lukas Jungmann 2007-01-19 17:15:58 UTC
This applies also to entity beans in J2EE 1.4
Comment 2 Martin Adamek 2007-01-19 18:41:24 UTC
I don't understand what is the problem in this issue? Is it only missing
business interface or also something else (there is plus sign)?
Comment 3 Lukas Jungmann 2007-01-19 18:51:02 UTC
the naming of classes is different then in previous version of the IDE (as in
issue 92396) "+" there's missing business interface

BTW: Is there some special reason why "Local" is now prefix and there's nothing
for "Remote" - no prefix nor suffix? Also why suffixes were changed to prefixes?
- I'm just watching ...ejbcore.naming.EJBNameOptions class...
Comment 4 Martin Adamek 2007-01-19 19:02:10 UTC
OK, I see. No special reason for current naming conventions, it is still work in
progress. It should follow
http://java.sun.com/blueprints/code/namingconventions.html
I want to create also UI for names customization later.
Comment 5 Martin Adamek 2007-02-08 10:37:56 UTC
Should be fixed in M7
Comment 7 Lukas Jungmann 2007-02-16 12:02:08 UTC
business interfaces are still not being generated, but the main part of the
issue was fixed (=>P3)
Comment 8 Jiri Prox 2007-09-17 20:32:04 UTC
Obsolete milestone, please reevaluate
Comment 9 martin_adamek 2007-10-09 12:15:07 UTC
Useful unly in EJB 2.1. Probably not for NB 6.0?
Comment 10 Lukas Jungmann 2007-10-09 12:18:17 UTC
I'm OK with moving this to post-6.0, unless anyone else objects
Comment 11 Jan Horvath 2007-10-09 13:31:34 UTC
I propose not to fix it, because the problem is solved in java ee 5 which is replacing old ejb 2.1.
Comment 12 _ jyothivasa 2008-11-07 22:43:36 UTC
Business interfaces are generated in both J2EE 1.4 and JavaEE 5 for session beans.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo